]> code.ossystems Code Review - openembedded-core.git/commitdiff
enchant: fix unrecognised option
authorRobert Yang <liezhi.yang@windriver.com>
Sat, 28 Dec 2013 14:23:32 +0000 (22:23 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jan 2014 10:41:59 +0000 (10:41 +0000)
Fix the unrecognised option --disable-binreloc, the configure now uses:

AM_CONDITIONAL(WITH_BINRELOC, test "x$br_cv_binreloc" = "xyes")

We can use br_cv_binreloc=no to fix it.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-support/enchant/enchant_1.6.0.bb

index c16a2a816a691dc8c2dca8fde22f625a60c2ea74..5c9359ba72e6470cc7cd9815f6ed94404aef614d 100644 (file)
@@ -17,7 +17,9 @@ SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz
 SRC_URI[md5sum] = "de11011aff801dc61042828041fb59c7"
 SRC_URI[sha256sum] = "2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03f7097f"
 
-EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell --disable-binreloc"
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} \
+               --enable-aspell br_cv_binreloc=no \
+               "
 
 FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${BPN} ${libdir}/${BPN}/*.so"
 FILES_${PN}-dev += "${libdir}/${BPN}/*{SOLIBSDEV} ${libdir}/${BPN}/*.la"