]> code.ossystems Code Review - openembedded-core.git/commitdiff
boost: backport glibc patch for new eglibc
authorSaul Wold <sgw@linux.intel.com>
Thu, 11 Jul 2013 20:06:07 +0000 (13:06 -0700)
committerSaul Wold <sgw@linux.intel.com>
Fri, 12 Jul 2013 17:12:12 +0000 (10:12 -0700)
The newer eglibc removed a macro that was being checked by the boost
code, this patch replaces that.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/boost/boost_1.54.0.bb
meta/recipes-support/boost/files/glibc.patch [new file with mode: 0644]

index 68f483cc6b5d4f3365e14e3c760dbe9be6a409fe..3cf88fa3c114cc72620992406eda386424c20eeb 100644 (file)
@@ -2,4 +2,5 @@ include boost-${PV}.inc
 include boost.inc
 
 SRC_URI += "file://arm-intrinsics.patch \
+            file://glibc.patch \
            "
diff --git a/meta/recipes-support/boost/files/glibc.patch b/meta/recipes-support/boost/files/glibc.patch
new file mode 100644 (file)
index 0000000..c33ea64
--- /dev/null
@@ -0,0 +1,26 @@
+------------------------------------------------------------------------
+r84950 | johnmaddock | 2013-07-04 02:13:23 -0700 (Thu, 04 Jul 2013) | 2 lines
+
+Patch for recent versions of glibc which always assume int64_t support.
+Fixes #8731.
+
+Upstream-Status: Backport
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: boost_1_54_0/boost/cstdint.hpp
+===================================================================
+--- boost_1_54_0.orig/boost/cstdint.hpp
++++ boost_1_54_0/boost/cstdint.hpp
+@@ -41,7 +41,10 @@
+ // so we disable use of stdint.h when GLIBC does not define __GLIBC_HAVE_LONG_LONG.
+ // See https://svn.boost.org/trac/boost/ticket/3548 and http://sources.redhat.com/bugzilla/show_bug.cgi?id=10990
+ //
+-#if defined(BOOST_HAS_STDINT_H) && (!defined(__GLIBC__) || defined(__GLIBC_HAVE_LONG_LONG))
++#if defined(BOOST_HAS_STDINT_H)                                       \
++  && (!defined(__GLIBC__)                                     \
++      || defined(__GLIBC_HAVE_LONG_LONG)                      \
++      || (defined(__GLIBC__) && ((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ >= 17)))))
+ // The following #include is an implementation artifact; not part of interface.
+ # ifdef __hpux