]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-nodm-init: Fix xuser creation
authorZhai Edwin <edwin.zhai@intel.com>
Fri, 16 Dec 2011 07:53:22 +0000 (15:53 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Dec 2011 16:03:30 +0000 (16:03 +0000)
Rootless X start fail as xuser has no home and shell. This patch fix it.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/x11-common/xserver-nodm-init.bb

index dbc1c42003585e49b0b1864caad61a89d6dc875d..99ef72ef5a9ae686e82e5a1942b0f8cfa2d9e870 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 SECTION = "x11"
-PR = "r28"
+PR = "r29"
 RDEPENDS_${PN} = "sudo"
 
 SRC_URI = "file://xserver-nodm \
@@ -31,7 +31,7 @@ INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
 # Use fixed Xusername of xuser for now, this will need to be
 # fixed if the Xusername changes from xuser
 USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --no-create-home \
-                       --shell /bin/false --groups video,tty,audio \
+USERADD_PARAM_${PN} = "--create-home \
+                       --groups video,tty,audio \
                        --user-group xuser"