]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: add grep to temporary links during uninstall
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Wed, 9 Nov 2011 11:33:41 +0000 (11:33 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 9 Nov 2011 14:58:14 +0000 (14:58 +0000)
In the busybox package prerm we set up some temporary links and modify
PATH so that certain utilities are provided for the purpose of running
update-alternatives; if grep is not among these then you get errors when
removing busybox, so add a temporary link for grep as well.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/recipes-core/busybox/busybox.inc
meta/recipes-core/busybox/busybox_1.18.5.bb

index acd635b1e3a027d6bef0e5fea88b9a7b99212fca..f8fee51725ecd79825602c85aacf7ac87f995cea 100644 (file)
@@ -270,6 +270,7 @@ pkg_prerm_${PN} () {
        ln -s /bin/busybox $tmpdir/rm
        ln -s /bin/busybox $tmpdir/sed
        ln -s /bin/busybox $tmpdir/sort
+       ln -s /bin/busybox $tmpdir/grep
        export PATH=$PATH:$tmpdir
 
        while read link
index bdafb316a5edf63da16d511bdd1751326b1c2b2f..17d583e6e38800907518d229d9ef26c1fba158b0 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://udhcpscript.patch \