]> code.ossystems Code Review - openembedded-core.git/commitdiff
Update to expat 2.0 (from OE)
authorRoss Burton <ross@openedhand.com>
Mon, 5 Mar 2007 10:05:41 +0000 (10:05 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 5 Mar 2007 10:05:41 +0000 (10:05 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1327 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/expat/expat-2.0.0/autotools.patch [new file with mode: 0644]
meta/packages/expat/expat.inc [new file with mode: 0644]
meta/packages/expat/expat_1.95.7.bb
meta/packages/expat/expat_2.0.0.bb [new file with mode: 0644]

diff --git a/meta/packages/expat/expat-2.0.0/autotools.patch b/meta/packages/expat/expat-2.0.0/autotools.patch
new file mode 100644 (file)
index 0000000..77aee3a
--- /dev/null
@@ -0,0 +1,13 @@
+diff -bur expat-2.0.0~orig/configure.in expat-2.0.0/configure.in
+--- expat-2.0.0~orig/configure.in      2006-01-10 19:10:46.000000000 -0600
++++ expat-2.0.0/configure.in   2006-02-10 19:12:24.000000000 -0600
+@@ -50,9 +50,6 @@
+ AC_CONFIG_HEADER(expat_config.h)
+-sinclude(conftools/libtool.m4)
+-sinclude(conftools/ac_c_bigendian_cross.m4)
+-
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
diff --git a/meta/packages/expat/expat.inc b/meta/packages/expat/expat.inc
new file mode 100644 (file)
index 0000000..6d27b77
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "Jim Clarkes XML parser library."
+HOMEPAGE = "http://expat.sf.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+         "
+S = "${WORKDIR}/expat-${PV}"
+
+export LTCC = "${CC}"
+
+inherit autotools
+
index c3bbb8981b3e5a0e1d7c1160e50c750ec2f1974d..a4dda4dcb63f314fbff647d7cc6d473dc225b5f1 100644 (file)
@@ -1,15 +1,9 @@
-SECTION = "libs"
-DESCRIPTION = "Jim Clarkes XML parser library."
-HOMEPAGE = "http://expat.sourceforge.net/"
-LICENSE = "MIT"
+require expat.inc
 PR = "r1"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
-          file://autotools.patch;patch=1"
-S = "${WORKDIR}/expat-${PV}"
+SRC_URI += "file://autotools.patch;patch=1"
 
-inherit autotools lib_package
-export LTCC = "${CC}"
+inherit lib_package
 
 do_configure () {
        rm -f ${S}/conftools/libtool.m4
diff --git a/meta/packages/expat/expat_2.0.0.bb b/meta/packages/expat/expat_2.0.0.bb
new file mode 100644 (file)
index 0000000..0fd825e
--- /dev/null
@@ -0,0 +1,27 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1"
+
+inherit lib_package
+
+do_configure() {
+       rm -f ${S}/conftools/libtool.m4
+       touch ${S}/conftools/libtool.m4
+       autotools_do_configure
+}
+
+do_stage() {
+       install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+       install -m 0644 ${S}/lib/expat_external.h ${STAGING_INCDIR}/
+       oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install() {
+       oe_runmake prefix="${D}${prefix}" \
+               bindir="${D}${bindir}" \
+               libdir="${D}${libdir}" \
+               includedir="${D}${includedir}" \
+               man1dir="${D}${mandir}/man1" \
+               install
+}