]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: don't use oe.path.relative
authorRoss Burton <ross.burton@intel.com>
Tue, 4 Mar 2014 16:46:02 +0000 (16:46 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Mar 2014 14:55:26 +0000 (14:55 +0000)
Instead of using oe.path.relative, use the Python Standard Library function
os.path.relpath.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/perf/perf.bb

index 6258cbbe096294769bd811764561bb486e6c4fae..56576d5d657fb8446146540d7e38547c2b4b21cb 100644 (file)
@@ -86,10 +86,10 @@ EXTRA_OEMAKE += "\
        'sysconfdir=${sysconfdir}' \
        'perfexecdir=${libexecdir}/perf-core' \
        \
-       'ETC_PERFCONFIG=${@oe.path.relative(prefix, sysconfdir)}' \
-       'sharedir=${@oe.path.relative(prefix, datadir)}' \
-       'mandir=${@oe.path.relative(prefix, mandir)}' \
-       'infodir=${@oe.path.relative(prefix, infodir)}' \
+       'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
+       'sharedir=${@os.path.relpath(datadir, prefix)}' \
+       'mandir=${@os.path.relpath(mandir, prefix)}' \
+       'infodir=${@os.path.relpath(infodir, prefix)}' \
 "
 
 # PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h