]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-desktop: do not assume time_t is long
authorJoe Slater <joe.slater@windriver.com>
Thu, 15 Mar 2018 16:03:31 +0000 (09:03 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 20 Mar 2018 09:30:16 +0000 (09:30 +0000)
Replace use of atol() to set a time_t variable.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-gnome/gnome-desktop/gnome-desktop/gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch [moved from meta/recipes-gnome/gnome-desktop/gnome-desktop/gnome-desktop-thumbnail-don-t-convert-time_t-to-long.patch with 70% similarity]
meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.26.2.bb

similarity index 70%
rename from meta/recipes-gnome/gnome-desktop/gnome-desktop/gnome-desktop-thumbnail-don-t-convert-time_t-to-long.patch
rename to meta/recipes-gnome/gnome-desktop/gnome-desktop/gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch
index c1a7d4f40f577a05d6ff0edef57e34972181b03a..fcc152fdef3cf3275dff93768c60f882c9d131bf 100644 (file)
@@ -9,6 +9,15 @@ build for X32, where long's size doesn't match that of time_t.
 Upstream-Status: Pending
 Signed-off-by: Christopher Larson <chris_larson@mentor.com>
 
+
+Modify patch described above to eliminate replacement of
+
+g_snprintf (mtime_str, 21, "%" G_GINT64_FORMAT, (gint64) mtime)
+
+which is not necessary.  Retain replacement of atol().
+
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
+
 ---
  libgnome-desktop/gnome-desktop-thumbnail.c | 16 ++++++++++++++--
  1 file changed, 14 insertions(+), 2 deletions(-)
@@ -26,27 +35,6 @@ index e56c3d7..5d96bf3 100644
  #include <config.h>
  
  #include <glib.h>
-@@ -1105,6 +1107,7 @@ save_thumbnail (GdkPixbuf  *pixbuf,
-   char *tmp_path = NULL;
-   int tmp_fd;
-   char mtime_str[21];
-+  struct tm *tmp_mtime = NULL;
-   gboolean ret = FALSE;
-   GError *error = NULL;
-   const char *width, *height;
-@@ -1124,7 +1127,11 @@ save_thumbnail (GdkPixbuf  *pixbuf,
-     goto out;
-   close (tmp_fd);
--  g_snprintf (mtime_str, 21, "%" G_GINT64_FORMAT, (gint64) mtime);
-+  tmp_mtime = localtime (&mtime);
-+  if (!tmp_mtime)
-+    goto out;
-+  strftime (mtime_str, 21, "%s", tmp_mtime);
-+  free (tmp_mtime);
-   width = gdk_pixbuf_get_option (pixbuf, "tEXt::Thumb::Image::Width");
-   height = gdk_pixbuf_get_option (pixbuf, "tEXt::Thumb::Image::Height");
 @@ -1319,6 +1326,7 @@ gnome_desktop_thumbnail_is_valid (GdkPixbuf          *pixbuf,
  {
    const char *thumb_uri, *thumb_mtime_str;
index cd6c194c1b71854553b2bc9cb20cc84172bfe580..879dc9a2f6e420f0fb9dd03bd64fb12603cb844c 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI[archive.md5sum] = "6cee2ecd677d87eaa0eb5ebfa7b45fb3"
 SRC_URI[archive.sha256sum] = "f7561a7a313fc474b2c390cd9696df1f5c1e1556080e43f4afe042b1060e5f2a"
 
 SRC_URI += " \
-           file://gnome-desktop-thumbnail-don-t-convert-time_t-to-long.patch \
+           file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \
            file://0001-configure.ac-Remove-gnome-common-macro-calls.patch \
            file://0001-Disable-libseccomp-sycall-filtering-mechanism.patch \
            "