]> code.ossystems Code Review - openembedded-core.git/commitdiff
bootchart2: update python interpreter
authorKai Kang <kai.kang@windriver.com>
Wed, 6 Sep 2017 10:22:46 +0000 (18:22 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Sep 2017 16:30:12 +0000 (17:30 +0100)
For bootchart2-native, the python interpreter "#!FIXMESTAGINGDIRHOST/usr/bin/python3"
of file pybootchartgui is not right.

Use '#!${USRBINPATH}/env python3' instead to fix the issue.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb

index 4f01734bb0b6bccddd02c63c3f9c4b5842b6a2f6..a3101351ee7c063ebe42c0eb80435262a8403a96 100644 (file)
@@ -134,7 +134,7 @@ do_install () {
     echo 'EXIT_PROC="$EXIT_PROC matchbox-window-manager"' >> ${D}${sysconfdir}/bootchartd.conf
 
    # Use python 3 instead of python 2
-   sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/pybootchartgui
+   sed -i -e '1s,#!.*python.*,#!${USRBINPATH}/env python3,' ${D}${bindir}/pybootchartgui
 }
 
 PACKAGES =+ "pybootchartgui"