]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipetool: create: pick up boost macros in configure.ac
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 18 Jan 2016 11:18:27 +0000 (00:18 +1300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 19 Jan 2016 16:35:38 +0000 (16:35 +0000)
The presence of BOOST_REQUIRE or AX_BOOST.* indicates that boost is a
dependency.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
scripts/lib/recipetool/create_buildsys.py

index 7fedb2a9173fd02748c8c2eedf6e15d7f813cd93..544dae32dbcfccd6222ba42ba304dd6186d668d9 100644 (file)
@@ -294,6 +294,8 @@ class AutotoolsRecipeHandler(RecipeHandler):
                                     unmappedlibs.append(lib)
             elif keyword == 'AC_PATH_X':
                 deps.append('libx11')
+            elif keyword in ('AX_BOOST', 'BOOST_REQUIRE'):
+                deps.append('boost')
             elif keyword == 'AC_INIT':
                 if extravalues is not None:
                     res = ac_init_re.match(value)
@@ -332,6 +334,8 @@ class AutotoolsRecipeHandler(RecipeHandler):
                     'AC_PATH_PROG',
                     'AC_CHECK_LIB',
                     'AC_PATH_X',
+                    'AX_BOOST',
+                    'BOOST_REQUIRE',
                     'AC_INIT',
                     'AM_INIT_AUTOMAKE',
                     'define(',