]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt4(embedded and x11): Disable neon for armv6-vfp
authorDenis Carikli <denis@eukrea.com>
Thu, 15 Sep 2011 09:26:16 +0000 (11:26 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 4 Oct 2011 10:34:21 +0000 (11:34 +0100)
Without the -no-neon flag, neon is "autodetected"
by looking if the compiler is capable of compiling
a neon test, and succeed, and neon is then enabled
during the compilation.

Signed-off-by: Denis Carikli <denis@eukrea.com>
meta/recipes-qt/qt4/qt4-embedded_4.7.3.bb
meta/recipes-qt/qt4/qt4-x11-free_4.7.3.bb

index c3f671319909bdb8977fd30d7ec86a352504546a..801b45ab8238392ce861d5e5262796d2dc0db902 100644 (file)
@@ -1,9 +1,9 @@
 require qt-${PV}.inc
 require qt4-embedded.inc
 
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 
-QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+QT_CONFIG_FLAGS_append_armv6-vfp = " -no-neon "
 
 QT_CONFIG_FLAGS += " \
  -exceptions \
index 75c6314e7fec9f79eece98e1595598380a64c823..413afb4a2df644a38e6ff279b91817d90fec4fb9 100644 (file)
@@ -1,9 +1,9 @@
 require qt4-x11-free.inc
 require qt-${PV}.inc
 
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 
-QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+QT_CONFIG_FLAGS_append_armv6-vfp = " -no-neon "
 
 QT_CONFIG_FLAGS += " \
  -no-embedded \