]> code.ossystems Code Review - openembedded-core.git/commitdiff
sato-icon-theme: unify 0.1 and svn
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 19 Oct 2007 14:16:11 +0000 (14:16 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 19 Oct 2007 14:16:11 +0000 (14:16 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2933 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/sato-icon-theme/sato-icon-theme.inc [new file with mode: 0644]
meta/packages/sato-icon-theme/sato-icon-theme_0.1.bb
meta/packages/sato-icon-theme/sato-icon-theme_svn.bb

diff --git a/meta/packages/sato-icon-theme/sato-icon-theme.inc b/meta/packages/sato-icon-theme/sato-icon-theme.inc
new file mode 100644 (file)
index 0000000..3c3699d
--- /dev/null
@@ -0,0 +1,21 @@
+require sato-icon-theme.inc
+
+SECTION = "x11"
+DESCRIPTION = "Sato Icon Theme"
+LICENSE = "CC-BY-SA3"
+DEPENDS = ""
+
+SRC_URI = "http://pokylinux.org/releases/sato/sato-icon-theme-0.1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}"
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+        if [ "x$D" != "x" ]; then
+                exit 1
+        fi
+        gtk-update-icon-cache -q /usr/share/icons/Sato
+}
index 30d0017b74d5b178a1f8420d9719a8bf388020f9..0a29175aa80ba4a772767f541fd4727a23be2d09 100644 (file)
@@ -1,19 +1,3 @@
-SECTION = "x11"
-DESCRIPTION = "Sato Icon Theme"
-LICENSE = "CC-BY-SA3"
-DEPENDS = ""
+require sato-icon-theme.inc
 
-SRC_URI = "http://pokylinux.org/releases/sato/sato-icon-theme-0.1.tar.gz"
-
-inherit autotools pkgconfig
-
-FILES_${PN} += "${datadir}"
-
-PACKAGE_ARCH = "all"
-
-pkg_postinst_${PN} () {
-        if [ "x$D" != "x" ]; then
-                exit 1
-        fi
-        gtk-update-icon-cache -q /usr/share/icons/Sato
-}
+SRC_URI = "http://pokylinux.org/releases/sato/sato-icon-theme-${PV}.tar.gz"
index 5d01e1f82cd7f3888874e9a46ff24d2273384dd5..595886ab99c2271eb0d95e19e5538f28d4bc524d 100644 (file)
@@ -1,21 +1,7 @@
-SECTION = "x11"
-DESCRIPTION = "Sato Icon Theme"
-LICENSE = "CC-BY-SA3"
-DEPENDS = ""
+require sato-icon-theme.inc
+
 PV = "0.1+svnr${SRCREV}"
 
 SRC_URI = "svn://svn.o-hand.com/repos/sato/trunk;module=sato-icon-theme;proto=http"
-S = "${WORKDIR}/sato-icon-theme"
-
-inherit autotools pkgconfig
 
-FILES_${PN} += "${datadir}"
-
-PACKAGE_ARCH = "all"
-
-pkg_postinst_${PN} () {
-        if [ "x$D" != "x" ]; then
-                exit 1
-        fi
-        gtk-update-icon-cache -q /usr/share/icons/Sato
-}
+S = "${WORKDIR}/sato-icon-theme"