]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: add routerstation pro and mpc8315e-rdb support
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 11 Jan 2011 18:08:29 +0000 (13:08 -0500)
committerSaul Wold <sgw@linux.intel.com>
Wed, 12 Jan 2011 08:55:49 +0000 (00:55 -0800)
The routerstation pro and mpc8315e-rdb have been validated
on 2.6.37 so we can switch their preference to linux-yocto
and update the machine compatibility to add them to the support
list.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/conf/machine/mpc8315e-rdb.conf
meta/conf/machine/routerstationpro.conf
meta/recipes-kernel/linux/linux-yocto_git.bb

index a41ca39404bc2d98bdfbb777276a4fdfe79fb48d..6b9809192d7e61e31e49412859ca37b02f33a0af 100644 (file)
@@ -102,7 +102,7 @@ SRCREV_machine_pn-linux-yocto_qemux86 ?= "a9d833fda90e2f1257888a97e092135610b5f2
 SRCREV_machine_pn-linux-yocto_qemux86-64 ?= "a9d833fda90e2f1257888a97e092135610b5f259"
 SRCREV_machine_pn-linux-yocto_emenlow ?= "a9d833fda90e2f1257888a97e092135610b5f259"
 SRCREV_machine_pn-linux-yocto_atom-pc ?= "a9d833fda90e2f1257888a97e092135610b5f259"
-SRCREV_machine_pn-linux-yocto_routerstationpro ?= "9d24b148fc23a2c8fab0a6add18500453b375d54"
+SRCREV_machine_pn-linux-yocto_routerstationpro ?= "219a5f9dc6e5beced36184e141f80b2df61ae32f"
 SRCREV_machine_pn-linux-yocto_mpc8315e-rdb ?= "3f01b98238c2ff7913ce9f68f9db5ae9538717bc"
 SRCREV_machine_pn-linux-yocto_beagleboard ?= "a9d833fda90e2f1257888a97e092135610b5f259"
 SRCREV_meta_pn-linux-yocto ?= "7102097a25c7658e0f4d4dc71844e0ff6c446b25"
index 919a95d9efd34e525042547bdef07dadf8060ac8..e3f9d2319d8bc93c4a0d4708d17d17ffaeef24bf 100644 (file)
@@ -12,5 +12,5 @@ SERIAL_CONSOLE = "115200 ttyS0"
 
 MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
 
-PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-stable"
-#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
+PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
index 4f1bbbb2c7b47e043c00dc2e557c124ba603de88..9e5036d86c8307c64b31a75b83c8a16a64f5a52e 100644 (file)
@@ -12,8 +12,8 @@ MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 \
 KERNEL_IMAGETYPE = "vmlinux"
 KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
 
-PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-stable"
-#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
+PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
 
 SERIAL_CONSOLE = "115200 ttyS0"
 
index 06836f78bd73a6cf3102ce9d23fc8e3af89ca895..21023da54b3d6a3b1fc44a74a73b60219d6c101d 100644 (file)
@@ -20,7 +20,7 @@ SRCREV_FORMAT = "meta_machine"
 SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
            git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta"
 
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|routerstationpro)"
 
 # Functionality flags
 KERNEL_REVISION_CHECKING ?= "t"