]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer_0.10.29.bb: Fix recipe metadata
authorDongxiao Xu <dongxiao.xu@intel.com>
Sat, 26 Jun 2010 06:52:15 +0000 (14:52 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 30 Jun 2010 12:14:34 +0000 (13:14 +0100)
Change LICENSE and HOMEPAGE information
Add LIC_FILES_CHKSUM and BUGTRACKER information
Adjust the variables order according to styleguide

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/packages/gstreamer/gstreamer_0.10.29.bb

index 72c155299e6db58f3e1dd655f26450162ff32340..38e28fa53484f89ffeef82833c9c421ad49bca85 100644 (file)
@@ -1,17 +1,22 @@
 DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
 It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
+HOMEPAGE = "http://gstreamer.freedesktop.org/"
+BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
 SECTION = "multimedia"
 PRIORITY = "optional"
-LICENSE = "LGPL"
-HOMEPAGE = "http://www.gstreamer.net/"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605 \
+                    file://gst/gst.h;beginline=1;endline=21;md5=8e5fe5e87d33a04479fde862e238eaa4"
 DEPENDS = "glib-2.0 gettext libxml2 bison-native flex-native"
-PR = "r0"
 
-inherit autotools pkgconfig
+PR = "r0"
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
            file://check_fix.patch;patch=1 \
            file://gst-inspect-check-error.patch;patch=1"
+
+inherit autotools pkgconfig
+
 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
 
 #do_compile_prepend () {