]> code.ossystems Code Review - openembedded-core.git/commitdiff
libidn2: Fix reproducibility issue
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 5 Feb 2020 15:55:16 +0000 (15:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Feb 2020 12:16:02 +0000 (12:16 +0000)
The previous tweak for reproducibility didn't handle the duplicate
whitepace left behind, fix this.

[YOCTO #13771]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/libidn/libidn2_2.3.0.bb

index 8e7e6c0dbcbe92a1356b88aecb783b7ff1eb7fb8..7adf924aebfe807009de4fc9a425ef052db2c33f 100644 (file)
@@ -22,7 +22,8 @@ EXTRA_OECONF += "--disable-rpath \
                  "
 
 do_install_append() {
-       sed -i -e 's|-L${STAGING_LIBDIR}||' ${D}${libdir}/pkgconfig/libidn2.pc
+       # Need to remove any duplicate whitespace too for reproducibility
+       sed -i -e 's|-L${STAGING_LIBDIR}||' -e 's/  */ /g' ${D}${libdir}/pkgconfig/libidn2.pc
 }
 
 LICENSE_${PN} = "(GPLv2+ | LGPLv3)"