]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpcre: the generated libtool uses HOST_SYS
authorChris Larson <chris_larson@mentor.com>
Fri, 19 Aug 2011 21:56:23 +0000 (14:56 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 24 Aug 2011 01:23:13 +0000 (18:23 -0700)
Signed-off-by: Chris Larson <chris_larson@mentor.com>
meta/recipes-support/libpcre/libpcre_8.12.bb

index 2972c1a51f32376f7dd29de38d4c145975d861ad..54d1f9840683ef4374e79c28998a669934bef1c4 100644 (file)
@@ -30,11 +30,11 @@ EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10
 do_compile () {
        # stop libtool from trying to link with host libraries - fix from #33
        # this resolve build problem on amd64 - #1015
-       if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
-               sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
+       if [ -e ${S}/${HOST_SYS}-libtool ] ; then
+               sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
        else
-               ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool
-               sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool    
+               ln -sf ${S}/libtool ${S}/${HOST_SYS}-libtool
+               sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
        fi
 
        # The generation of dftables can lead to timestamp problems with ccache