]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-pycryptodome(x): Upgrade 3.9.4 -> 3.9.7
authorJoshua Watt <JPEWhacker@gmail.com>
Thu, 14 May 2020 21:04:57 +0000 (16:04 -0500)
committerSteve Sakoman <steve@sakoman.com>
Wed, 3 Jun 2020 14:30:27 +0000 (04:30 -1000)
Also splits apart the SRC_URI checksums to make automatic upgrades
easier

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit ae1f210546396b761ea86d9e32bf90c0867ff845)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/python/python-pycryptodome.inc
meta/recipes-devtools/python/python3-pycryptodome_3.9.4.bb [deleted file]
meta/recipes-devtools/python/python3-pycryptodome_3.9.7.bb [new file with mode: 0644]
meta/recipes-devtools/python/python3-pycryptodomex_3.9.7.bb [moved from meta/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb with 58% similarity]

index 63b4a4abb4e42e5e634e734f37782abba74aee1b..68b084eb04fa2062592d9473ddc6e9daea894dd0 100644 (file)
@@ -5,9 +5,6 @@ HOMEPAGE = "http://www.pycryptodome.org"
 LICENSE = "PD & BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=6dc0e2a13d2f25d6f123c434b761faba"
 
-SRC_URI[md5sum] = "f990716b49add7b14ea8b8a961fb3746"
-SRC_URI[sha256sum] = "a168e73879619b467072509a223282a02c8047d932a48b74fbd498f27224aa04"
-
 inherit pypi
 
 RDEPENDS_${PN} += " \
diff --git a/meta/recipes-devtools/python/python3-pycryptodome_3.9.4.bb b/meta/recipes-devtools/python/python3-pycryptodome_3.9.4.bb
deleted file mode 100644 (file)
index 0c062dd..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-pycryptodome.inc
-inherit setuptools3
diff --git a/meta/recipes-devtools/python/python3-pycryptodome_3.9.7.bb b/meta/recipes-devtools/python/python3-pycryptodome_3.9.7.bb
new file mode 100644 (file)
index 0000000..8f19984
--- /dev/null
@@ -0,0 +1,5 @@
+require python-pycryptodome.inc
+inherit setuptools3
+
+SRC_URI[sha256sum] = "f1add21b6d179179b3c177c33d18a2186a09cc0d3af41ff5ed3f377360b869f2"
+
similarity index 58%
rename from meta/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
rename to meta/recipes-devtools/python/python3-pycryptodomex_3.9.7.bb
index e41c14b142d6940c1ec184738fefa77cec52ab7e..abb03b9909d4e5f971cf2d5ef0ab9eadf890322b 100644 (file)
@@ -1,8 +1,7 @@
 require python-pycryptodome.inc
 inherit setuptools3
 
-SRC_URI[md5sum] = "46ba513d95b6e323734074d960a7d57b"
-SRC_URI[sha256sum] = "22d970cee5c096b9123415e183ae03702b2cd4d3ba3f0ced25c4e1aba3967167"
+SRC_URI[sha256sum] = "50163324834edd0c9ce3e4512ded3e221c969086e10fdd5d3fdcaadac5e24a78"
 
 FILES_${PN}-tests = " \
     ${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/ \