]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: Sync with OE.dev
authorRichard Purdie <richard@openedhand.com>
Tue, 21 Nov 2006 10:02:56 +0000 (10:02 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 21 Nov 2006 10:02:56 +0000 (10:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@902 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/busybox/busybox-1.01/nylon/defconfig
meta/packages/busybox/busybox-1.01/uclibc_posix.patch
meta/packages/busybox/busybox-1.01/xargs-double-size.patch [new file with mode: 0644]
meta/packages/busybox/busybox_1.01.bb

index 599051bafbe4b5aedbe7413fdcfe96a03e98ea3f..3e4257ef04a45c441e66fbc29970ecbc535cc341 100644 (file)
@@ -51,7 +51,7 @@ CONFIG_GZIP=y
 # CONFIG_RPM is not set
 CONFIG_TAR=y
 CONFIG_FEATURE_TAR_CREATE=y
-CONFIG_FEATURE_TAR_BZIP2=y
+# CONFIG_FEATURE_TAR_BZIP2 is not set
 CONFIG_FEATURE_TAR_FROM=y
 CONFIG_FEATURE_TAR_GZIP=y
 CONFIG_FEATURE_TAR_COMPRESS=y
index aefb994068812013337010665ed2128ffdac56ea..186f3f9c3a5ad6036dd583fad46cab5ae4d75065 100644 (file)
@@ -1,12 +1,13 @@
 see http://www.busybox.net/lists/busybox/2004-December/013276.html
+and http://bugs.openembedded.org/show_bug.cgi?id=657
 
---- busybox-old/libbb/loop.c   2004-08-16 04:36:28.000000000 -0400
-+++ busybox/libbb/loop.c       2004-12-04 23:45:58.000000000 -0500
+--- busybox-1.01/libbb/loop.c  2006/03/13 22:18:47     1.1
++++ busybox-1.01/libbb/loop.c  2006/03/13 22:19:57
 @@ -19,6 +19,7 @@
   * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
   */
  
-+#include <asm/posix_types.h>
++#include <linux/types.h>
  #include <stdio.h>
  #include <errno.h>
  #include <fcntl.h>
diff --git a/meta/packages/busybox/busybox-1.01/xargs-double-size.patch b/meta/packages/busybox/busybox-1.01/xargs-double-size.patch
new file mode 100644 (file)
index 0000000..218d6c0
--- /dev/null
@@ -0,0 +1,13 @@
+--- busybox-1.01/findutils/xargs.c.org 2006-09-19 18:18:17.084592997 +0200
++++ busybox-1.01/findutils/xargs.c     2006-09-19 18:18:09.820275793 +0200
+@@ -466,8 +466,8 @@
+                  have it at 1 meg).  Things will work fine with a large ARG_MAX but it
+                  will probably hurt the system more than it needs to; an array of this
+                  size is allocated.  */
+-              if (orig_arg_max > 20 * 1024)
+-                      orig_arg_max = 20 * 1024;
++              if (orig_arg_max > 40 * 1024)
++                      orig_arg_max = 40 * 1024;
+               n_max_chars = orig_arg_max;
+       }
+       max_chars = xmalloc(n_max_chars);
index 996b5418a4704b97ad88b739c2a7f1ec4c5290e3..9c8b7e60c374e340675daf6ebee4d38d96855826 100644 (file)
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.busybox.net"
 LICENSE = "GPL"
 SECTION = "base"
 PRIORITY = "required"
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
           file://udhcppidfile.patch;patch=1 \
@@ -28,8 +28,8 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
           file://rmmod.patch;patch=1 \
           file://udhcpscript.patch;patch=1 \
           file://thumb-bsdlabel.patch;patch=1 \
+          file://glibc2.4-icmp6.patch;patch=1 \
            file://uclibc_posix.patch;patch=1 \
-           file://glibc2.4-icmp6.patch;patch=1 \
            file://defconfig \
            file://busybox-cron \
           file://busybox-httpd \
@@ -40,7 +40,9 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
           file://syslog.conf \
           file://mount.busybox \
           file://umount.busybox"
+
 SRC_URI_append_slugos += " file://sysctl.conf "
+SRC_URI_append_nylon = " file://xargs-double-size.patch;patch=1"
 
 S = "${WORKDIR}/busybox-${PV}"
 
@@ -85,7 +87,7 @@ do_install () {
        install -d ${D}${base_bindir}
        mv ${D}/busybox${base_bindir}/busybox ${D}${base_bindir}/
        # Move back the sh symlink
-       mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/
+       test -h ${D}/busybox${base_bindir}/sh && mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/
 
        install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/
        install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/