]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: move systemtap-exporter into separate package
authorVictor Kamensky <kamensky@cisco.com>
Fri, 26 Oct 2018 02:59:55 +0000 (19:59 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 28 Oct 2018 08:31:49 +0000 (08:31 +0000)
stap-exporter runs a set of systemtap scripts and relays
their procfs outputs to remote HTTP clients on demand.

systemtap-exporter is not supposed to run in untrusted
environment. It starts HTTP server on some port. It does
not look safe enough to be included by default along with
the rest of systemtap.

Move systemtap-exporter, its systemd unit, configuration
files and examples scripts into separate package. So if one
needs it and understand its implication, he/she can include
it explicitely.

Signed-off-by: Victor Kamensky <kamensky@cisco.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/systemtap/systemtap_git.bb

index 904ecdd10622669469dea9758912c0967e1b7030..6ee3e1c0f78d5100f6fe6fc85c1430473b54af2a 100644 (file)
@@ -27,7 +27,16 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
 
 inherit autotools gettext pkgconfig distutils3-base systemd
 
-SYSTEMD_SERVICE_${PN} = "stap-exporter.service"
+PACKAGES =+ "${PN}-exporter"
+
+FILES_${PN}-exporter = "${sysconfdir}/stap-exporter/* \
+                        ${sysconfdir}/sysconfig/stap-exporter \
+                        ${systemd_unitdir}/system/stap-exporter.service \
+                        ${sbindir}/stap-exporter"
+
+RDEPENDS_${PN}-exporter = "${PN} python3-core python3-netclient"
+
+SYSTEMD_SERVICE_${PN}-exporter = "stap-exporter.service"
 
 do_configure_prepend () {
     # Improve reproducibility for c++ object files