]> code.ossystems Code Review - openembedded-core.git/commitdiff
Adjust the exception handling based on Cliff Brake's patch
authorChris Larson <chris_larson@mentor.com>
Fri, 4 Jun 2010 23:44:07 +0000 (16:44 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 2 Jul 2010 14:41:35 +0000 (15:41 +0100)
Rather than printing the exception ourselves, might as well re-raise and let
the default exception handler do it for us.

(Bitbake rev: acca7eb8450cbe30d65b5b266f1a642e7965df8a)

Signed-off-by: Chris Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake

index 7880968965cd1feea01317587696395bac6ece9b..600cdadc9d9438eeb3c3d2cd32541cd760981347 100755 (executable)
@@ -206,7 +206,8 @@ Default BBFILES are the .bb files in the current directory.""")
         print "FATAL: Invalid user interface '%s' specified. " % ui
         print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
     except Exception, e:
-        print "FATAL: Unable to start to '%s' UI due to exception: %s." % (configuration.ui, e)
+        print "FATAL: Unable to start to '%s' UI: %s" % (configuration.ui, e)
+        raise
     finally:
         serverConnection.terminate()
         return return_value