]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools.bbclass: Copy gettext files only if --disable-nls is not set
authorKhem Raj <raj.khem@gmail.com>
Mon, 25 Apr 2011 01:38:48 +0000 (18:38 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 28 Apr 2011 08:52:29 +0000 (09:52 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/classes/autotools.bbclass

index 7ebf833603d75faae7ecae2f1b2c90d5b5d0625d..cbd2e9666e61ff0867b26f7ec1433f82bb09efd6 100644 (file)
@@ -127,17 +127,18 @@ autotools_do_configure() {
                        else
                          CONFIGURE_AC=configure.ac
                        fi
-                       if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
-                         if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
-                           : do nothing -- we still have an old unmodified configure.ac
-                         else
-                           oenote Executing glib-gettextize --force --copy
-                           echo "no" | glib-gettextize --force --copy
+                       if ! echo ${EXTRA_OECONF} | grep -q "\-\-disable-nls"; then
+                         if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+                           if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
+                             : do nothing -- we still have an old unmodified configure.ac
+                           else
+                             oenote Executing glib-gettextize --force --copy
+                             echo "no" | glib-gettextize --force --copy
+                           fi
+                         else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+                           cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
                          fi
-                       else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
-                         cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
                        fi
-
                        fi
                        mkdir -p m4
                        if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then