]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-nodm: Disable dbus-wait as it causes users too much confusion
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 30 Aug 2011 21:23:38 +0000 (22:23 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 18:30:29 +0000 (19:30 +0100)
In the event the xserver fails to start the dbus-wait has to time out and
this causes many users a lot of confusion. If we wish to reinstate this,
we need to find a safer mechanism to do it where X failing to start cancels
the timeout (sends a dbus event at that point?) The comments are left in the
file as an example in case some user does wish to enable is.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/x11-common/xserver-nodm-init.bb
meta/recipes-graphics/x11-common/xserver-nodm-init/xserver-nodm

index d48f700f2dad6bfed7b1f365d5b4a14f7bfe23b2..ea4222df7742067161a551f37222a4707d804605 100644 (file)
@@ -2,8 +2,8 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 SECTION = "x11"
-PR = "r25"
-RDEPENDS_${PN} = "dbus-wait sudo"
+PR = "r26"
+RDEPENDS_${PN} = "sudo"
 
 SRC_URI = "file://xserver-nodm \
            file://Xusername \
index 3b71983c0acab12aaf54ead8fe18dca484dcb226..858af0b67e18e5a9009f201073b8977989915c38 100755 (executable)
@@ -38,7 +38,8 @@ case "$1" in
        # Using su rather than sudo as latest 1.8.1 cause failure [YOCTO #1211]
        su -l -c '/etc/X11/Xserver&' $username 
        # Wait for the desktop to say its finished loading
-       dbus-wait org.matchbox_project.desktop Loaded
+       # before loading the rest of the system
+       # dbus-wait org.matchbox_project.desktop Loaded
   ;;
 
   stop)