]> code.ossystems Code Review - openembedded-core.git/commitdiff
nfs-utils: fix start-statd
authorRoy.Li <rongqing.li@windriver.com>
Mon, 20 Oct 2014 05:38:14 +0000 (13:38 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 Oct 2014 16:31:58 +0000 (17:31 +0100)
1. add /bin to PATH of start-statd, otherwise systemctl can not be found.
2. drop error when systemd fails to start statd.service; since if it failed,
rpc.statd will be called directly.

Signed-off-by: Roy.Li <rongqing.li@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/nfs-utils/nfs-utils/fix-the-start-statd.patch [new file with mode: 0644]
meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb

diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils/fix-the-start-statd.patch b/meta/recipes-connectivity/nfs-utils/nfs-utils/fix-the-start-statd.patch
new file mode 100644 (file)
index 0000000..b7e835e
--- /dev/null
@@ -0,0 +1,30 @@
+[PATCH] fix the start-statd
+
+Upstream-Status: Pending
+
+1. add /bin/ to PATH, since systemctl is installed under /bin/
+2. redirect error to /dev/null
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ utils/statd/start-statd |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/utils/statd/start-statd b/utils/statd/start-statd
+index cde3583..098ce70 100644
+--- a/utils/statd/start-statd
++++ b/utils/statd/start-statd
+@@ -4,8 +4,8 @@
+ # /var/run/rpc.statd.pid).
+ # It should run statd with whatever flags are apropriate for this
+ # site.
+-PATH=/sbin:/usr/sbin
+-if systemctl start statd.service
++PATH=/sbin:/usr/sbin:/bin
++if systemctl start statd.service 2>/dev/null
+ then :
+ else
+     exec rpc.statd --no-notify
+-- 
+1.7.10.4
+
index f1ef6d9a0cab6fb14e959435f2810a152a2de74d..4933e10403f20378f3b8c4537c0b746fbc3dc71f 100644 (file)
@@ -32,6 +32,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.x
            file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
            file://0001-statd-fixed-the-with-statdpath-flag.patch \
            file://fix-a-Gcc-undefined-behavior.patch \
+           file://fix-the-start-statd.patch \
 "
 
 SRC_URI[md5sum] = "6e93a7997ca3a1eac56bf219adab72a8"