]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: remove /absolute/path/to/host references
authorOoi Cinly <cinly.ooi@intel.com>
Wed, 16 Aug 2017 01:17:50 +0000 (09:17 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Aug 2017 11:35:58 +0000 (12:35 +0100)
Removed all instances of -fdebug-prefix-map in LTCFLAGS
declaration because they contain references to host system
and are not needed.

/absolute/path/to/host/dd was replaced with 'dd' in
lt_truncate_bin declaration.

Please take note that the location of regex is important
for DEBUG_PREFIX_MAP. Removal of DEBUG_PREFIX_MAP has to be
done before other regex command modify its option value.

Both are modified because they affect binary reproducibility.

[YOCTO #11656]

Signed-off-by: Ooi Cinly <cinly.ooi@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/libtool/libtool_2.4.6.bb

index 06abb055841061effa3143a5207dbf7184c4c125..b02620b4b41e75948d11c8fa86471f61ca59e3db 100644 (file)
@@ -15,6 +15,7 @@ ACLOCALEXTRAPATH_class-target = ""
 
 do_install_append () {
         sed -e 's@--sysroot=${STAGING_DIR_HOST}@@g' \
+            -e "s@${DEBUG_PREFIX_MAP}@@g" \
             -e 's@${STAGING_DIR_HOST}@@g' \
             -e 's@${STAGING_DIR_NATIVE}@@g' \
             -e 's@^\(sys_lib_search_path_spec="\).*@\1${libdir} ${base_libdir}"@' \
@@ -22,5 +23,6 @@ do_install_append () {
             -e 's@^\(compiler_lib_search_path="\).*@\1${libdir} ${base_libdir}"@' \
             -e 's@^\(predep_objects="\).*@\1"@' \
             -e 's@^\(postdep_objects="\).*@\1"@' \
+            -e "s@${HOSTTOOLS_DIR}/@@g" \
             -i ${D}${bindir}/libtool
 }