]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xf86-lite: Add a non-dri version of the server for use when dri/gl isn't...
authorRichard Purdie <richard@openedhand.com>
Mon, 29 Sep 2008 19:47:52 +0000 (19:47 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 29 Sep 2008 19:47:52 +0000 (19:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5323 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xorg-xserver/xserver-xf86-lite.inc [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-lite/drmfix.patch [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-lite/libdri-xinerama-symbol.patch [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-lite_1.5.0.bb [new file with mode: 0644]

diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite.inc b/meta/packages/xorg-xserver/xserver-xf86-lite.inc
new file mode 100644 (file)
index 0000000..fe20d20
--- /dev/null
@@ -0,0 +1,32 @@
+require xserver-xf86-common.inc
+
+PROVIDES += "xserver-xf86-lite"
+
+PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86rushproto xf86vidmodeproto xf86bigfontproto compositeproto recordproto resourceproto videoproto scrnsaverproto evieext trapproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto glproto"
+
+LIB_DEPS = "pixman libxfont xtrans libxau libxext libxdmcp libdrm libxkbfile libpciaccess openssl"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+RDEPENDS = "hal xorg-minimal-fonts"
+
+FILES_${PN} += "${bindir}/Xorg "
+
+EXTRA_OECONF += "--disable-cfb \
+                 --disable-afb \
+                 --disable-mfb \
+                 --disable-dga \
+                 --disable-xinerama \
+                 --disable-xf86misc \
+                 --disable-xorgcfg \
+                 --disable-dmx \
+                 --disable-xnest \
+                 --disable-xvfb \
+                 --enable-composite \
+                 --disable-dri \
+                 --disable-glx \
+                 --sysconfdir=/etc/X11 \
+                 --localstatedir=/var \
+                 --with-fontdir=/usr/share/fonts/X11 \
+                 --with-xkb-output=/var/lib/xkb \
+                 ac_cv_file__usr_share_sgml_X11_defs_ent=no"
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/drmfix.patch b/meta/packages/xorg-xserver/xserver-xf86-lite/drmfix.patch
new file mode 100644 (file)
index 0000000..a62a767
--- /dev/null
@@ -0,0 +1,13 @@
+Index: xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am
+===================================================================
+--- xorg-server-1.4.orig/hw/xfree86/os-support/linux/Makefile.am       2007-08-23 21:04:53.000000000 +0200
++++ xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am    2008-03-13 18:27:23.000000000 +0100
+@@ -41,7 +41,7 @@
+ AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(DIX_CFLAGS) $(XORG_CFLAGS) $(PLATFORM_DEFINES)
+-INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) -I/usr/include/drm # FIXME this last part is crack
++INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) $(LIBDRM_CFLAGS)
+ # FIXME: These need to be added to the build
+ LNX_EXTRA_SRCS = \
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/libdri-xinerama-symbol.patch b/meta/packages/xorg-xserver/xserver-xf86-lite/libdri-xinerama-symbol.patch
new file mode 100644 (file)
index 0000000..db29da9
--- /dev/null
@@ -0,0 +1,50 @@
+Index: xorg-server-1.5.0/hw/xfree86/dri/dri.c
+===================================================================
+--- xorg-server-1.5.0.orig/hw/xfree86/dri/dri.c        2008-09-24 17:43:04.000000000 +0100
++++ xorg-server-1.5.0/hw/xfree86/dri/dri.c     2008-09-24 17:46:38.000000000 +0100
+@@ -73,10 +73,6 @@
+ #define PCI_BUS_NO_DOMAIN(bus) ((bus) & 0xffu)
+-#if !defined(PANORAMIX)
+-extern Bool noPanoramiXExtension;
+-#endif
+-
+ static int DRIEntPrivIndex = -1;
+ static DevPrivateKey DRIScreenPrivKey = &DRIScreenPrivKey;
+ static DevPrivateKey DRIWindowPrivKey = &DRIWindowPrivKey;
+@@ -307,7 +303,6 @@
+     drm_context_t *       reserved;
+     int                 reserved_count;
+     int                 i;
+-    Bool                xineramaInCore = FALSE;
+     DRIEntPrivPtr       pDRIEntPriv;
+     ScrnInfoPtr         pScrn = xf86Screens[pScreen->myNum];
+     DRIContextFlags   flags    = 0;
+@@ -320,20 +315,13 @@
+       return FALSE;
+     }
+-    /*
+-     * If Xinerama is on, don't allow DRI to initialise.  It won't be usable
+-     * anyway.
+-     */
+-    if (xf86LoaderCheckSymbol("noPanoramiXExtension"))
+-      xineramaInCore = TRUE;
+-
+-    if (xineramaInCore) {
+-      if (!noPanoramiXExtension) {
+-          DRIDrvMsg(pScreen->myNum, X_WARNING,
+-              "Direct rendering is not supported when Xinerama is enabled\n");
+-          return FALSE;
+-      }
++#if defined(PANORAMIX)
++    if (!noPanoramiXExtension) {
++        DRIDrvMsg(pScreen->myNum, X_WARNING,
++            "Direct rendering is not supported when Xinerama is enabled\n");
++        return FALSE;
+     }
++#endif
+     if (!DRIOpenDRMMaster(pScrn, pDRIInfo->SAREASize,
+                         pDRIInfo->busIdString,
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf
new file mode 100644 (file)
index 0000000..44a530e
--- /dev/null
@@ -0,0 +1,87 @@
+
+Section "Files"
+EndSection
+
+Section "InputDevice"
+    Identifier    "Generic Keyboard"
+    Driver        "kbd"
+    Option        "CoreKeyboard"
+    Option        "XkbRules"    "xorg"
+    Option        "XkbModel"    "pc105"
+    Option        "XkbLayout"    "us"
+EndSection
+
+Section "InputDevice"
+    Identifier    "Configured Mouse"
+    Driver        "mouse"
+    Option        "CorePointer"
+    Option        "Device"        "/dev/input/mice"
+    Option        "Protocol"        "ImPS/2"
+    Option        "ZAxisMapping"        "4 5"
+    Option        "Emulate3Buttons"    "true"
+EndSection
+
+Section "InputDevice"
+    Identifier    "Synaptics Touchpad"
+    Driver        "synaptics"
+    Option        "SendCoreEvents"    "true"
+    Option        "Device"        "/dev/psaux"
+    Option        "Protocol"        "auto-dev"
+    Option        "HorizEdgeScroll"    "0"
+EndSection
+
+Section "InputDevice"
+    Driver        "wacom"
+    Identifier    "stylus"
+    Option        "Device"    "/dev/input/wacom"
+    Option        "Type"        "stylus"
+    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
+EndSection
+
+Section "InputDevice"
+    Driver        "wacom"
+    Identifier    "eraser"
+    Option        "Device"    "/dev/input/wacom"
+    Option        "Type"        "eraser"
+    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
+EndSection
+
+Section "InputDevice"
+    Driver        "wacom"
+    Identifier    "cursor"
+    Option        "Device"    "/dev/input/wacom"
+    Option        "Type"        "cursor"
+    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
+EndSection
+
+Section "Device"
+    Identifier    "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
+    Driver        "intel"
+    BusID        "PCI:0:2:0"
+EndSection
+
+Section "Monitor"
+    Identifier    "Generic Monitor"
+    Option        "DPMS"
+EndSection
+
+Section "Screen"
+    Identifier    "Default Screen"
+    Device        "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
+    Monitor        "Generic Monitor"
+    DefaultDepth    24
+EndSection
+
+Section "ServerLayout"
+    Identifier    "Default Layout"
+    Screen        "Default Screen"
+    InputDevice    "Generic Keyboard"
+    InputDevice    "Configured Mouse"
+
+# Uncomment if you have a wacom tablet
+#    InputDevice     "stylus"    "SendCoreEvents"
+#    InputDevice     "cursor"    "SendCoreEvents"
+#    InputDevice     "eraser"    "SendCoreEvents"
+    InputDevice    "Synaptics Touchpad"
+EndSection
+
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite_1.5.0.bb b/meta/packages/xorg-xserver/xserver-xf86-lite_1.5.0.bb
new file mode 100644 (file)
index 0000000..d16e7b0
--- /dev/null
@@ -0,0 +1,7 @@
+require xserver-xf86-lite.inc
+
+PR = "r0"
+
+SRC_URI += "file://drmfix.patch;patch=1 \
+            file://libdri-xinerama-symbol.patch;patch=1 "
+