]> code.ossystems Code Review - openembedded-core.git/commitdiff
gpgme: Avoid requiring a host C++ compiler with C++11 support
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Mon, 20 Mar 2017 15:13:08 +0000 (16:13 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Mar 2017 22:43:03 +0000 (22:43 +0000)
Building the C++ bindings for native requires a host C++ compiler with
C++11 support. Since these bindings are currently not needed, we can
disable them and thus avoid increasing the requirement for the host C++
compiler.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/gpgme/gpgme_1.8.0.bb

index d3e7880a47ba58ed30b0c9acb06d07341d0bc561..2756ef815d5b0268f09512862dc4446b3217ef9b 100644 (file)
@@ -34,7 +34,11 @@ PACKAGECONFIG[python3] = ",,python3 swig-native,"
 # Supported: "cl cpp python python2 python3 qt"
 # python says 'search and find python2 or python3'
 
-LANGUAGES ?= "cpp"
+# Building the C++ bindings for native requires a C++ compiler with C++11
+# support. Since these bindings are currently not needed, we can disable them.
+DEFAULT_LANGUAGES = ""
+DEFAULT_LANGUAGES_class-target = "cpp"
+LANGUAGES ?= "${DEFAULT_LANGUAGES}"
 LANGUAGES .= "${@bb.utils.contains('PACKAGECONFIG', 'python2', ' python2', '', d)}"
 LANGUAGES .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', ' python3', '', d)}"