]> code.ossystems Code Review - openembedded-core.git/commitdiff
icu: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 02:05:05 +0000 (02:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:39 +0000 (13:17 +0000)
Fix out of tree builds by fixing cwd assumptions and using correct
full paths where needed, or just simply the correct paths.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/icu/icu.inc

index 64b3edf3ca73811f6d2a1144111121fb2e2fd2c3..d7cb84a40020b49344645d1c3f6bcfad21986964 100644 (file)
@@ -27,15 +27,15 @@ EXTRA_OECONF_class-native = ""
 # This is a bug of ICU. See bug reference:
 # http://bugs.icu-project.org/trac/ticket/9790
 do_configure_prepend() {
-    [ -f acinclude.m4 ] || cp aclocal.m4 acinclude.m4
+    [ -f ${S}/acinclude.m4 ] || cp ${S}/aclocal.m4 ${S}/acinclude.m4
 }
 
 do_install_append_class-native() {
        mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
-       cp -r ${S}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
-       cp -r ${S}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
-       cp -r ${S}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
-       cp -r ${S}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
+       cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
+       cp -r ${B}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
+       cp -r ${B}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
+       cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
 
 }