]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.4: gpio-pca953x: add PCAL9535 interrupt support
authorBruce Ashfield <bruce.ashfield@windriver.com>
Sat, 2 Apr 2016 00:09:20 +0000 (20:09 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 Apr 2016 14:51:09 +0000 (15:51 +0100)
Reverting two previous gpio commits to allow the application of proper
upstream ready patches to add this support:

  08943f2bbd50 gpio-pca953x: add "drive" property
  a517d5b72e76 gpio: pca953x: provide GPIO base based on _UID
  c91063f44368 gpio-pca953x: add PCAL9535 interrupt support
  58f3c9f0ac6d Revert "gpio-pca953x: add "drive" property"
  7abbd5fec15d Revert "gpio: pca953x: provide GPIO base based on _UID"

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
meta/recipes-kernel/linux/linux-yocto_4.4.bb

index 48025c48af025c28c2657557cc00298e477dc43a..e6a03928b9b09f5a08063bd24b511c73215c52e5 100644 (file)
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt"
 
 require recipes-kernel/linux/linux-yocto.inc
 
-SRCREV_machine ?= "5ff13cb449701bfeb30ea4a0c4c0b86dc680e219"
+SRCREV_machine ?= "56434a6d9850fd3642bab5cab63d22c6f56d2eae"
 SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
index 7583f8019f07707fdde1a5195605b2cbbc0ef45f..2b7e1cb4d723b53699662874d7a819d0073694e8 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.4.3"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "c43425f73287757a166d74464fddf1f5389c9f59"
+SRCREV_machine ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
 SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 3d6991e8998a172e8e46548d0641df7e9d22f146..49038caf943e72446f8cdeec1477d6c9ba373ab2 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "19185ca77bc28b0198868f65d6c6c2a92a7ee24c"
-SRCREV_machine_qemuarm64 ?= "c43425f73287757a166d74464fddf1f5389c9f59"
-SRCREV_machine_qemumips ?= "0921347362bc9a4f63a62774a68a1b013cdfc5c4"
-SRCREV_machine_qemuppc ?= "c43425f73287757a166d74464fddf1f5389c9f59"
-SRCREV_machine_qemux86 ?= "c43425f73287757a166d74464fddf1f5389c9f59"
-SRCREV_machine_qemux86-64 ?= "c43425f73287757a166d74464fddf1f5389c9f59"
-SRCREV_machine_qemumips64 ?= "b09e103786fc1a0622e89bac9df4254e6cb96baa"
-SRCREV_machine ?= "c43425f73287757a166d74464fddf1f5389c9f59"
+SRCREV_machine_qemuarm ?= "03f244ec7482dbc1c924af73a317dd3d12f00132"
+SRCREV_machine_qemuarm64 ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
+SRCREV_machine_qemumips ?= "4cd732b14cf4bdb51b7b565783bbc2ce5ab9a943"
+SRCREV_machine_qemuppc ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
+SRCREV_machine_qemux86 ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
+SRCREV_machine_qemux86-64 ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
+SRCREV_machine_qemumips64 ?= "699473bc2476afa85e47833f0f47aaf44a799257"
+SRCREV_machine ?= "08943f2bbd507f8b7f5ef101ccc4755cbec79aad"
 SRCREV_meta ?= "770996a263e22562c81f48fde0f0dc647156abce"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \