]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: Fix parsing error
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 19 Mar 2013 13:22:59 +0000 (13:22 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 19 Mar 2013 13:23:47 +0000 (13:23 +0000)
Due to the use of ${@...} the code will try and expand this when
performing the initial parsing. If the sysroot doesn't exist with
an existing kernel, this will fail at parsing time.

Sinec we're already in python, just remove the ${@....} wrapping
and then we execute at do_package time which is what we want.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 182dd25d6eafe3a9be1929f57381443d287a799c..210c4cbf65fddce4fdf16b4019dd10c61b999d17 100644 (file)
@@ -105,7 +105,7 @@ do_configure_prepend () {
 }
 
 python do_package_prepend() {
-    bb.data.setVar('PKGV', '${@get_kernelversion('${S}').split("-")[0]}', d)
+    bb.data.setVar('PKGV', get_kernelversion('${S}').split("-")[0], d)
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"