]> code.ossystems Code Review - openembedded-core.git/commitdiff
libiconv: Fix B != S with uclibc builds
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 May 2014 13:49:50 +0000 (14:49 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 8 May 2014 11:56:42 +0000 (12:56 +0100)
Without this, uclibc builds fail with libtool version mismatches. The issue
is that we need to remove the files in ${S}, not ${B} which is now
the default after the B != S change.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/libiconv/libiconv_1.14.bb

index a670e2c62e8f7332ec8cd035c8aeedd85175c8f7..d5f47b4e347b9a8a51e094ce7b3600a5f9417fb5 100644 (file)
@@ -34,7 +34,7 @@ EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable"
 LEAD_SONAME = "libiconv.so"
 
 do_configure_prepend () {
-       rm -f m4/libtool.m4 m4/ltoptions.m4 m4/ltsugar.m4 m4/ltversion.m4 m4/lt~obsolete.m4 libcharset/m4/libtool.m4 libcharset/m4/ltoptions.m4 libcharset/m4/ltsugar.m4 libcharset/m4/ltversion.m4 libcharset/m4/lt~obsolete.m4
+       rm -f ${S}/m4/libtool.m4 ${S}/m4/ltoptions.m4 ${S}/m4/ltsugar.m4 ${S}/m4/ltversion.m4 ${S}/m4/lt~obsolete.m4 ${S}/libcharset/m4/libtool.m4 ${S}/libcharset/m4/ltoptions.m4 ${S}/libcharset/m4/ltsugar.m4 ${S}/libcharset/m4/ltversion.m4 ${S}/libcharset/m4/lt~obsolete.m4
 }
 
 do_configure_append () {