]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkitgtk/epiphany: add opengl to REQUIRED_DISTRO_FEATURES
authorHongxu Jia <hongxu.jia@windriver.com>
Wed, 10 Oct 2018 07:16:48 +0000 (15:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2018 11:42:51 +0000 (12:42 +0100)
They can't be built without opengl in DISTRO_FEATURES.
[snip]
|webkitgtk-2.20.3/Source/WebCore/platform/graphics/OpenGLShims.h:23:10:
fatal error: GL/gl.h: No such file or directory
[snip]

Some sort of GL is needed yes. We indicate that with opengl loosely in OE

The epiphany depends on webkitgtk, add opengl to REQUIRED_DISTRO_FEATURES also.

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/epiphany/epiphany_3.28.3.1.bb
meta/recipes-sato/webkit/webkitgtk_2.20.5.bb

index 8837b9c1d91f4db9ec2c7fb9224a8219fb98941b..b46c9d3b468b6e78b5248a1c3fd611655d631e8f 100644 (file)
@@ -8,7 +8,7 @@ DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes avahi libnotify gcr \
 
 GNOMEBASEBUILDCLASS = "meson"
 inherit gnomebase gsettings distro_features_check upstream-version-is-even gettext
-REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
 
 SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
            file://0002-help-meson.build-disable-the-use-of-yelp.patch \
index c8d4f94f19f784c7e3c023a8985399fe7fadec8f..7f1ffcea4547df39ebf48ae8645a0040e1bf612e 100644 (file)
@@ -30,8 +30,7 @@ SRC_URI[sha256sum] = "15c0f8d26e9605afe0948d161ba5fd82efee8eda2debd409fd40a440ac
 
 inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc
 
-# depends on libxt
-REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
 
 DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn libgcrypt \
            gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \