]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-foo: add description to each image bb file
authorShane Wang <shane.wang@intel.com>
Fri, 20 Jan 2012 05:46:06 +0000 (13:46 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jan 2012 11:23:53 +0000 (11:23 +0000)
Add DESCRIPTION to each image bb file according to poky reference manual for Hob2 use later.

Signed-off-by: Shane Wang <shane.wang@intel.com>
14 files changed:
meta/recipes-core/images/core-image-base.bb
meta/recipes-core/images/core-image-core.bb
meta/recipes-core/images/core-image-minimal-dev.bb
meta/recipes-core/images/core-image-minimal-initramfs.bb
meta/recipes-core/images/core-image-minimal-mtdutils.bb
meta/recipes-core/images/core-image-minimal.bb
meta/recipes-extended/images/core-image-basic.bb
meta/recipes-extended/images/core-image-lsb-dev.bb
meta/recipes-extended/images/core-image-lsb-sdk.bb
meta/recipes-extended/images/core-image-lsb.bb
meta/recipes-graphics/images/core-image-clutter.bb
meta/recipes-sato/images/core-image-sato-dev.bb
meta/recipes-sato/images/core-image-sato-sdk.bb
meta/recipes-sato/images/core-image-sato.bb

index 13a76508a06be74dec9ac469d147178b2f854fba..71ff3b94acbc022b78d220ef7671a79dc06f674b 100644 (file)
@@ -1,6 +1,8 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
+DESCRIPTION = "A console-only image that fully supports the target device \
+hardware."
 
 IMAGE_FEATURES += "apps-console-core"
 
index 57ff0850dac4a0ed8b008063235e283b86c257da..2d768e0b78b9b06a36faab082a3ab99e682fd0ca 100644 (file)
@@ -1,6 +1,8 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
+DESCRIPTION = "An X11 image with simple applications such as terminal, editor \
+and file manager."
 
 IMAGE_FEATURES += "apps-console-core ${X11_IMAGE_FEATURES}"
 
index 89ec9f88335ee927620eecea6f27f62c67d9d797..3a0a1879ecac499e279d8ccc8e3339434450a01d 100644 (file)
@@ -1,6 +1,8 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
+DESCRIPTION = "A core-image-minimal image suitable for development work."
+
 IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE}"
 
 IMAGE_FEATURES += "dev-pkgs"
index 5149f31546174b54f88b85b677874a87d25c69eb..85b9ff9b3f9111e339e3e8d1bfd00d26faf96658 100644 (file)
@@ -1,4 +1,7 @@
 # Simple initramfs image. Mostly used for live images.
+DESCRIPTION = "A core-image-minimal image that has the Minimal RAM-based \
+Initial Root Filesystem (initramfs) as part of the kernel, which allows the \
+system to find the first 'init' program more efficiently."
 
 IMAGE_INSTALL = "initramfs-live-boot initramfs-live-install busybox udev base-passwd"
 
index adabaa400aaf946ca6ba232fe0370d95dc236419..7b7f700618a17bb2c989c7c9954f4c39bd622d5e 100644 (file)
@@ -3,4 +3,8 @@
 #
 require core-image-minimal.bb
 
+DESCRIPTION = "A core-image-minimal image that has support the Minimal MTD \
+Utilities, which let the user interact with the MTD subsystem in the kernel \
+to perform operations on flash devices."
+
 IMAGE_INSTALL += "mtd-utils"
index 56fc20ce05fef5925dfdb7baa378839e0a5906d2..687f72a4cc918e378ab706c802376033535f1133 100644 (file)
@@ -1,6 +1,8 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
+DESCRIPTION = "A small image just capable of allowing a device to boot."
+
 IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${POKY_EXTRA_INSTALL}"
 
 IMAGE_LINGUAS = " "
index ba71cd091e4b9e9adf5ea71d269b0b782995a4cb..5e58e60100d179fcbcae19d9a1c8c33909863036 100644 (file)
@@ -1,3 +1,6 @@
+DESCRIPTION = "A foundational basic image without support for X that can be \
+reasonably used for customization."
+
 IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
 
 IMAGE_INSTALL = "\
index 9ef85ff8aae456c5f63dce4a84d76de5c785f633..2d6f6744a8d0977d9b1b152bf641b145eb58a921 100644 (file)
@@ -1,3 +1,7 @@
+DESCRIPTION = "A core-image-lsb that includes everything in meta-toolchain \
+but also includes development headers and libraries to form a complete \
+standalone SDK."
+
 IMAGE_FEATURES += "apps-console-core dev-pkgs ssh-server-openssh"
 
 IMAGE_INSTALL = "\
index 5e0e7aea4008ad343004b2e3a9cc9ac81f0049d7..105c8db8a85fc79b849f609404206db5f1b02982 100644 (file)
@@ -1,3 +1,7 @@
+DESCRIPTION = "A core-image-lsb that includes everything in meta-toolchain \
+but also includes development headers and libraries to form a complete \
+standalone SDK."
+
 IMAGE_FEATURES += "apps-console-core tools-sdk dev-pkgs ssh-server-openssh"
 EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
 
index 22eb7f48e9efe57118cd6ef91d35f99a1559a56b..f6696183e6c64fe503f2c64f2a4aef1000b4c2d3 100644 (file)
@@ -1,3 +1,6 @@
+DESCRIPTION = "A core-image-basic image suitable for implementations that \
+conform to Linux Standard Base (LSB)."
+
 IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
 
 IMAGE_INSTALL = "\
index 7d50405617fe5df0e5d79ea481abeecc26542a69..636238a6d198b28cb2a5e372904182cdb2658839 100644 (file)
@@ -1,3 +1,6 @@
+DESCRIPTION = "An image with support for the Open GL-based toolkit Clutter, \
+which enables development of rich and animated graphical user interfaces."
+
 IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES}"
 
 LICENSE = "MIT"
index 7322b4afbe808e1340d7f0c44c56e28a5406f91b..b30447c5833be157594146d2a16e4a7fe53b5c45 100644 (file)
@@ -1,6 +1,9 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
+DESCRIPTION = "A core-image-sato image suitable for development that also \
+includes a native toolchain and libraries needed to build applications on the \
+device itself."
 
 IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs"
 
index 6c2dc60100283c6c1c0a4cab8b5c7b75da859632..2cf8cadea75ee4ec2fe45f3bc18a4797ccb34425 100644 (file)
@@ -1,7 +1,9 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
-
+DESCRIPTION = "A core-image-sato image that includes everything in \
+meta-toolchain. The image also includes development headers and libraries \
+to form a complete standalone SDK."
 
 IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs tools-sdk qt4-pkgs"
 EXTRA_IMAGE_FEATURES += "tools-debug tools-profile tools-testapps debug-tweaks"
index 3465174a5b7f179beb1ad70f0858249afd896d24..11c33180013a5ec033fbfaae96fb0c4ebcfb0e74 100644 (file)
@@ -1,6 +1,8 @@
 #
 # Copyright (C) 2007 OpenedHand Ltd.
 #
+DESCRIPTION = "An image with Sato support, a mobile environment and visual \
+style that works well with mobile devices."
 
 IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES}"