]> code.ossystems Code Review - openembedded-core.git/commitdiff
findutils: fix sort dir on updatedb
authorRoy.Li <rongqing.li@windriver.com>
Wed, 25 Jul 2012 08:07:39 +0000 (16:07 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Jul 2012 13:46:16 +0000 (14:46 +0100)
[YOCTO #2826]

m4/nullsort.m4 tries to find sort dir, and write it to updatedb,
but nullsort.m4 is checking the host dir. Once the sort dirs on
target and host are different, updatedb will fail due to wrong
sort dir.

Since we always have sort under ${bindir}, so we can assign it
directly.

Signed-off-by: Roy.Li <rongqing.li@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/findutils/findutils_4.4.2.bb

index 127eb4b1881cb14aa945dc2a1a5bb64ec9ba78b1..218bf8344356c08814d2857e0ed65234e075f140 100644 (file)
@@ -1,6 +1,6 @@
 require findutils.inc
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://01-27017.patch \
             file://02-28824.patch \
@@ -15,4 +15,6 @@ SRC_URI[sha256sum] = "434f32d171cbc0a5e72cfc5372c6fc4cb0e681f8dce566a0de5b6fccd7
 # http://savannah.gnu.org/bugs/?27299
 CACHED_CONFIGUREVARS += "${@base_contains('DISTRO_FEATURES', 'libc-posix-clang-wchar', 'gl_cv_func_wcwidth_works=yes', '', d)}"
 
+EXTRA_OECONF += "ac_cv_path_SORT=${bindir}/sort"
+
 BBCLASSEXTEND = "native"