]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: avoid parsing error when 'networkd' is enabled in PACKAGECONFIG
authorChen Qi <Qi.Chen@windriver.com>
Mon, 2 Mar 2015 07:37:48 +0000 (15:37 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Mar 2015 16:00:15 +0000 (16:00 +0000)
If 'networkd' is enabled in PACKAGECONFIG, the do_install variable cannot
be correctly expanded. Error message is like below.

Failure expanding variable do_install: ShellSyntaxError: LexToken(Fi,'fi',0,0)
followed by:
  LexToken(NEWLINE,'\n',0,0)

This patch fixes the above problem.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_219.bb

index 24486f1815e0fb8ae579020b443ddebd990f90be..d5c14a42c41300290c9321660540c9b4654fa975 100644 (file)
@@ -170,7 +170,7 @@ do_install() {
        # this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
        # for existence else it fails
        if [ -s ${D}${libdir}/tmpfiles.d/systemd.conf ]; then
-               ${@bb.utils.contains('PACKAGECONFIG', 'networkd', '', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
+               ${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
        fi
 }