]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-poky: Remove references to chkhinge26 as zaurusd now handles this. Correct...
authorRichard Purdie <richard@openedhand.com>
Fri, 28 Jul 2006 15:01:05 +0000 (15:01 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 28 Jul 2006 15:01:05 +0000 (15:01 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@574 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
meta/packages/matchbox-poky/matchbox-poky_0.1.bb

index 90073e0f13044a0364fc4f922f4a400336c4e024..a3dd6e56a0490c083c61ca606484ebaaf80e366d 100755 (executable)
@@ -8,9 +8,7 @@ SHOWCURSOR="no"
 
 ## Start up machine specific input devices. Really needs to go in its own session
 case `module_id` in
-       "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
-               chkhinge26 /dev/input/event0 hinge-handler &
-               ;;
+       # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts
        "Generic OMAP1510/1610/1710")
                /usr/bin/mbinputmgr &
                ;;
index 4eae590074e16c03c8df7b4d0ccc0d2a591ed958..7a4eb729994e0443b82395ee8cc5fa83312fb730 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r16"
+PR = "r19"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}
@@ -16,5 +16,9 @@ do_install() {
 
 pkg_postinst_matchbox-poky () {
 #!/bin/sh -e
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/theme Clearlooks
+if [ "x$D" != "x" ]; then
+    exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Clearlooks
 }