]> code.ossystems Code Review - openembedded-core.git/commitdiff
blktrace: refresh patches
authorRoss Burton <ross.burton@intel.com>
Fri, 9 Mar 2018 18:56:09 +0000 (20:56 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 11 Mar 2018 13:25:23 +0000 (06:25 -0700)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/blktrace/blktrace/ldflags.patch

index 29eb0f2728a463c369f5622382edcca993f6d37d..ab905cf0da3fa8c6680cf3136c4872e8db77151a 100644 (file)
@@ -10,6 +10,8 @@ aed463414e2e2bf8ca44ba54ee5973e7ed599e57
 
 Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
 
+Index: git/Makefile
+===================================================================
 --- git.orig/Makefile
 +++ git/Makefile
 @@ -1,5 +1,6 @@
@@ -19,7 +21,7 @@ Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
  ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
  PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
  LIBS  = -lpthread
-@@ -23,19 +24,19 @@ btreplay/btreplay:
+@@ -26,19 +27,19 @@ btreplay/btreplay:
        $(CC) -o $*.o -c $(ALL_CFLAGS) $<
  
  blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
@@ -44,6 +46,8 @@ Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
  
  $(PROGS): | depend
  
+Index: git/btreplay/Makefile
+===================================================================
 --- git.orig/btreplay/Makefile
 +++ git/btreplay/Makefile
 @@ -7,6 +7,7 @@
@@ -55,8 +59,8 @@ Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
  OCFLAGS       = -UCOUNT_IOS -UDEBUG -DNDEBUG
  XCFLAGS       = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
 @@ -32,10 +33,10 @@ clean: docsclean
-       $(CC) $(CFLAGS) -c -o $*.o $<
-
+       $(CC) $(CFLAGS) -c -o $*.o $<
  btrecord: btrecord.o
 -      $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
 +      $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LDFLAGS)
@@ -67,6 +71,8 @@ Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
  
  depend:
        @$(CC) -MM $(CFLAGS) *.c 1> .depend
+Index: git/btt/Makefile
+===================================================================
 --- git.orig/btt/Makefile
 +++ git/btt/Makefile
 @@ -7,6 +7,7 @@
@@ -86,10 +92,12 @@ Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
  
  ifneq ($(wildcard .depend),)
  include .depend
+Index: git/iowatcher/Makefile
+===================================================================
 --- git.orig/iowatcher/Makefile
 +++ git/iowatcher/Makefile
 @@ -1,5 +1,6 @@
- C      = gcc
+ CC      = gcc
  CFLAGS  = -Wall -O2 -g -W -Wunused-result
 +LDFLAGS =
  ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64