]> code.ossystems Code Review - openembedded-core.git/commitdiff
distcc: Make sure the distcc user exists
authorRichard Purdie <richard@openedhand.com>
Thu, 22 Nov 2007 18:01:54 +0000 (18:01 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 22 Nov 2007 18:01:54 +0000 (18:01 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3207 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/distcc/distcc_2.18.3.bb

index 7f557c41d1abfd989776c86e7a53404b82e0dd57..d52f696cb3c31b18c7f87c1565344c102c9779ef 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "distcc is a parallel build system that distributes \
 compilation of C/C++/ObjC code across machines on a network."
 SECTION = "devel"
 LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
 
 DEPENDS = "avahi gtk+"
 RRECOMMENDS = "avahi-daemon"
@@ -33,3 +33,13 @@ FILES_${PN} = " ${sysconfdir} \
                ${bindir}/distccmon-text"
 FILES_distcc-distmon-gnome = "  ${bindir}/distccmon-gnome \
                                ${datadir}/distcc"
+
+pkg_postinst() {
+       if test "x$D" != "x"; then
+               exit 1
+       else
+               grep distcc /etc/passwd || adduser --system --home /dev/null --empty-password --ingroup nogroup distcc
+       fi
+}
+       
+               
\ No newline at end of file