]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: fix postinst to not touch host system
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 26 Mar 2008 09:31:03 +0000 (09:31 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 26 Mar 2008 09:31:03 +0000 (09:31 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4120 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/bash/bash.inc
meta/packages/bash/bash_3.2.bb

index 80aedfa1c8e8a04e154fd6ac06442ea8063bd71a..b67e8bbe39de310267c58ebd76edc6abb8caa595 100644 (file)
@@ -20,7 +20,7 @@ do_configure () {
 }
 
 pkg_postinst () {
-       touch ${sysconfdir}/shells
-       grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
-       grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+       touch $D${sysconfdir}/shells
+       grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
+       grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
 }
index 95c1a73a5d5d772bd2c2743fd20e38e45c9ee474..883df501948c1459a01415ee3710617860803e3c 100644 (file)
@@ -1,5 +1,5 @@
 require bash.inc
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
            http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-001;patch=1;pnum=0 \