]> code.ossystems Code Review - openembedded-core.git/commitdiff
bluez4: use PACKAGECONFIG to control 'pie'
authorChristopher Larson <chris_larson@mentor.com>
Fri, 20 Jul 2012 16:24:06 +0000 (09:24 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Jul 2012 13:07:22 +0000 (14:07 +0100)
This lets us control whether we build position independent executables. As, as
far as I know no distros are adding a 'pie' distro feature, the effect of this
commit for most will be to disable pie in bluez4. I think this is best to
ensure consistent behavior among the recipes with regard to this.

This also sidesteps a build failure I've seen with bluez4 failing due to
libudev.a not having been built fPIC.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/bluez/bluez4.inc
meta/recipes-connectivity/bluez/bluez4_4.101.bb

index 6dc06f46b99c91633a7f96ec8f7c4ba82e8a045c..6ddd58df0c2448c31832c824b81218aafcdaeccf 100644 (file)
@@ -10,8 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
 DEPENDS = "udev libusb dbus-glib glib-2.0 libcheck"
 RDEPENDS_${PN}-dev = "bluez-hcidump"
 
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
+PACKAGECONFIG ??= "\
+    ${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}\
+    ${@base_contains('DISTRO_FEATURES', 'pie', 'pie', '', d)}\
+"
 PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
+PACKAGECONFIG[pie] = "--enable-pie,--disable-pie,"
 
 ASNEEDED = ""
 
index 4a360b693e423cfa128cf01ddc27a7334776f1a5..e26d4eac8bd30c0ffc102b54200667e0401d95ae 100644 (file)
@@ -1,6 +1,6 @@
 require bluez4.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI += "file://bluetooth.conf \
             file://sbc_mmx.patch"