]> code.ossystems Code Review - openembedded-core.git/commitdiff
baremetal-helloworld: Fix IMGDEPLOYDIR expansion
authorAlejandro Hernandez <alejandro@enedino.org>
Mon, 27 Apr 2020 22:33:28 +0000 (15:33 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Apr 2020 14:00:36 +0000 (15:00 +0100)
IMGDEPLOYDIR is not being expanded anymore, this causes
do_rootfs to fail because it can't create the manifest file,
we can set it to the default being set on image.bbclass since
this is only a decoy function anyway to satisfy testimage,
this makes do_rootfs happy and allows it to continue.

Signed-off-by: Alejandro Hernandez Samaniego <alejandro@enedino.org>
Signed-off-by: Alejandro Hernandez Samaniego <alhe@linux.microsoft.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb

index d8633702fca71c539ad741e63200576de846ad40..e84a90f28c75cbab0a68318067f6625c2587dc6d 100644 (file)
@@ -37,6 +37,7 @@ do_install(){
 # Borrowed from meta-freertos
 inherit rootfs-postcommands
 inherit deploy
+IMGDEPLOYDIR ?= "${WORKDIR}/deploy-${PN}-image-complete"
 do_deploy[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}"
 do_rootfs[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}"
 DEPLOYDIR = "${IMGDEPLOYDIR}"