]> code.ossystems Code Review - openembedded-core.git/commitdiff
man-pages: Fix to allow re-execution of tasks
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 15 Apr 2012 15:32:29 +0000 (16:32 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 15 Apr 2012 16:30:57 +0000 (17:30 +0100)
The all target in the makefile triggers "screen" and "remove" targets,
neither of which do anything useful/sane for our usecases. The simplest
way to get the makefile to behave is to only use the install target.

Clean up the recipe a bit whilst making these changes and simplify things.

[YOCTO #2194]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/man-pages/man-pages_3.36.bb

index 4e888dc07e786153f2ec3b8f7f1b257780d9b3f8..6025a875756814d2c94c07de1c22b1c09f78632d 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C libr
 SECTION = "console/utils"
 HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
 LICENSE = "GPLv2+"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://README;md5=0422377a748010b2b738342e24f141c1"
 SRC_URI = "${KERNELORG_MIRROR}/linux/docs/man-pages/Archive/${BPN}-${PV}.tar.gz"
@@ -13,19 +13,15 @@ SRC_URI[sha256sum] = "c0575e31f73cd9dc2761c274217e06e7130fdfee510170957a9d72d012
 
 RDEPENDS_${PN} = "man"
 
-do_configure_prepend() {
-       rm -rf not_installed
-}
-
 do_configure () {
-      :
+       :
 }
 
 do_compile() {
-       oe_runmake -f Makefile DESTDIR=${D} MANDIR=${D}${mandir}
+       :
 }
 
-fakeroot do_install() {
+do_install() {
         oe_runmake install DESTDIR=${D}
 }