]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg: Convert to BBCLASSEXTEND
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 13 Jan 2010 23:25:08 +0000 (23:25 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 13 Jan 2010 23:25:08 +0000 (23:25 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/dpkg/dpkg-native_1.14.19.bb [deleted file]
meta/packages/dpkg/dpkg.inc
meta/packages/dpkg/dpkg/autofoo.patch [moved from meta/packages/dpkg/files/autofoo.patch with 100% similarity]
meta/packages/dpkg/dpkg/ignore_extra_fields.patch [moved from meta/packages/dpkg/files/ignore_extra_fields.patch with 100% similarity]
meta/packages/dpkg/dpkg/nochroot.patch [moved from meta/packages/dpkg/files/nochroot.patch with 100% similarity]
meta/packages/dpkg/dpkg/noman.patch [moved from meta/packages/dpkg/files/noman.patch with 100% similarity]
meta/packages/dpkg/dpkg/noupdalt.patch [moved from meta/packages/dpkg/files/noupdalt.patch with 100% similarity]
meta/packages/dpkg/dpkg_1.14.19.bb

diff --git a/meta/packages/dpkg/dpkg-native_1.14.19.bb b/meta/packages/dpkg/dpkg-native_1.14.19.bb
deleted file mode 100644 (file)
index bf947b5..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-require dpkg.inc
-DEPENDS += "bzip2-native zlib-native virtual/update-alternatives-native"
-SRC_URI += "file://noman.patch;patch=1"
-
-inherit native
-
-EXTRA_OECONF = "--without-static-progs \
-               --without-dselect \
-               --with-start-stop-daemon \
-               --with-zlib \
-               --with-bz2lib \
-                --without-selinux \
-               --without-sgml-doc"
index 67c0781ce802b47c7b760a36a546a95367a2332a..d002b3ec8af2a66e51db80fc1113b62bb6477c4c 100644 (file)
@@ -7,7 +7,11 @@ SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz \
            file://ignore_extra_fields.patch;patch=1 \
            file://noupdalt.patch;patch=1"
 
-S = "${WORKDIR}/dpkg-${PV}"
+DEPENDS = "zlib bzip2"
+DEPENDS_virtclass-native = "bzip2-native zlib-native virtual/update-alternatives-native"
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+
+S = "${WORKDIR}/${BPN}-${PV}"
 
 PARALLEL_MAKE = ""
 
index 1a7991d40e50ee151aa871972ee07c70b2f8c879..1e54306c9354c0d8ea15bbd7401d2135c3efd019 100644 (file)
@@ -1,6 +1,4 @@
 require dpkg.inc
-DEPENDS += "zlib bzip2"
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
 
 SRC_URI += "file://noman.patch;patch=1"
 
@@ -9,4 +7,7 @@ EXTRA_OECONF = "--without-static-progs \
                --with-start-stop-daemon \
                --with-zlib \
                --with-bz2lib \
+               --without-selinux \
                --without-sgml-doc"
+
+BBCLASSEXTEND = "native"