]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-igep2: Fix audio capture, the capture result is always silence
authorEnric Balletbo i Serra <eballetbo@iseebcn.com>
Tue, 27 Oct 2009 12:18:59 +0000 (13:18 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 12 Nov 2009 16:51:41 +0000 (16:51 +0000)
Signed-off-by: Enric Balletbo i Serra <eballetbo@iseebcn.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/linux/linux-igep2-2.6.28.10-0/twl-asoc-fix-record.diff [new file with mode: 0644]
meta/packages/linux/linux-igep2_2.6.28.10-0.bb

diff --git a/meta/packages/linux/linux-igep2-2.6.28.10-0/twl-asoc-fix-record.diff b/meta/packages/linux/linux-igep2-2.6.28.10-0/twl-asoc-fix-record.diff
new file mode 100644 (file)
index 0000000..9c0ceaa
--- /dev/null
@@ -0,0 +1,34 @@
+From linux-omap-owner@vger.kernel.org Sat Dec 06 02:14:21 2008
+Date:  Fri, 5 Dec 2008 16:46:34 -0800
+From: "Steve Sakoman" <sakoman@gmail.com>
+To: "linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>
+Subject: [FYI PATCH] ASOC:TWL4030 Audio capture fix
+
+A couple of folks have noticed an issue with audio capture -- the
+capture result is always silence.
+
+The patch below is a quick fix for those with this issue.  There are
+substantial changes to the codec driver that will be trickling down
+from ASoC, and they deal with this issue differently.
+
+So consider this as a bandaid for those who don't want to wait for the
+trickle down :-)
+
+Steve
+
+
+diff --git a/sound/soc/codecs/twl4030.c b/sound/soc/codecs/twl4030.c
+index ee2f0d3..8b4aafb 100644
+--- a/sound/soc/codecs/twl4030.c
++++ b/sound/soc/codecs/twl4030.c
+@@ -45,8 +45,8 @@ static const u8 twl4030_reg[TWL4030_CACHEREGNUM] = {
+       0xc3, /* REG_OPTION             (0x2)   */
+       0x00, /* REG_UNKNOWN            (0x3)   */
+       0x00, /* REG_MICBIAS_CTL        (0x4)   */
+-      0x24, /* REG_ANAMICL            (0x5)   */
+-      0x04, /* REG_ANAMICR            (0x6)   */
++      0x34, /* REG_ANAMICL            (0x5)   */
++      0x14, /* REG_ANAMICR            (0x6)   */
+       0x0a, /* REG_AVADC_CTL          (0x7)   */
+       0x00, /* REG_ADCMICSEL          (0x8)   */
+       0x00, /* REG_DIGMIXING          (0x9)   */
index 9eec02878cb3cf8585f8528bce924f17f5316c32..e7e7ccf3fa5636e9cedacc3834fc9785b5fc4a49 100644 (file)
@@ -7,9 +7,13 @@ COMPATIBLE_MACHINE = "igep0020b"
 
 DEFAULT_PREFERENCE_igep0020b = "1"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://downloads.myigep.com/sources/kernel/linux-omap-2.6.28.10-igep0020b-0.tar.gz \
           file://defconfig"
 
+SRC_URI_append = " \
+          file://twl-asoc-fix-record.diff;patch=1 \
+       "
+
 S = "${WORKDIR}/linux-omap-2.6.28.10-igep0020b-0"