]> code.ossystems Code Review - openembedded-core.git/commitdiff
libaio: Remove QA warning: No GNU_HASH in the elf binary
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>
Wed, 5 Dec 2012 11:40:06 +0000 (16:40 +0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:37 +0000 (12:30 +0000)
Update the LINK_FLAGS in the Makefile to remove warning:
QA Issue: No GNU_HASH in the elf binary

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/libaio/libaio_0.3.109.bb

index 161b712a48ed1736b0ac780361643a40a9fd1cbd..0712d04e711464929dc56484e45688f9bedb4096 100644 (file)
@@ -18,6 +18,10 @@ SRC_URI[sha256sum] = "bf4a457253cbaab215aea75cb6e18dc8d95bbd507e9920661ff9bdd288
 
 EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
 
+do_configure () {
+    sed -i 's#LINK_FLAGS=.*#LINK_FLAGS=$(LDFLAGS)#' src/Makefile
+}
+
 do_install () {
     oe_runmake install DESTDIR=${D}
 }