]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp: disable elf binary stripping
authorNitin A Kamble <nitin.a.kamble@intel.com>
Fri, 20 Jan 2012 18:11:10 +0000 (10:11 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jan 2012 11:23:58 +0000 (11:23 +0000)
Otherwise the ltp tests ldd01 & nm01 fail due to missing stripped
information.

This Fixes these bugs:
[YOCTO #1922]
[YOCTO #1923]

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-extended/ltp/ltp_20110915.bb

index dabc0f02e50e3a325f06333416cfd909555f9732..f1e58b2fc383f944e26f00d5c9391e1b02ec70ec 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, an
 HOMEPAGE = "http://ltp.sourceforge.net"
 SECTION = "console/utils"
 
-PR = "r0"
+PR = "r1"
 
 LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
@@ -66,3 +66,7 @@ do_install(){
        # We will add expect for enhancement in future
        find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
 }
+
+# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
+INHIBIT_PACKAGE_STRIP = "1"
+