]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: fix /var/log/journal ownership
authorJonathan Liu <net147@gmail.com>
Thu, 12 Mar 2015 09:18:56 +0000 (20:18 +1100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Mar 2015 17:38:51 +0000 (17:38 +0000)
The ownership needs to be explicitly set otherwise it inherits the user
and group id of the build user.

Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_219.bb

index 238ee6707b2e6a3f71a89014803941f77179162f..ff29a3fecf125d0546e1f17bc17f5b2960808dc1 100644 (file)
@@ -154,6 +154,8 @@ do_install() {
                sed -i s%@UDEVD@%${rootlibexecdir}/systemd/systemd-udevd% ${D}${sysconfdir}/init.d/systemd-udevd
        fi
 
+       chown root:systemd-journal ${D}/${localstatedir}/log/journal
+
         # Delete journal README, as log can be symlinked inside volatile.
         rm -f ${D}/${localstatedir}/log/README