]> code.ossystems Code Review - openembedded-core.git/commitdiff
libevdev: update to 1.9.0
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 30 Apr 2020 09:58:11 +0000 (11:58 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 May 2020 14:38:03 +0000 (15:38 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libevdev/libevdev/determinism.patch
meta/recipes-support/libevdev/libevdev_1.9.0.bb [moved from meta/recipes-support/libevdev/libevdev_1.8.0.bb with 78% similarity]

index 33a6076b7813a9b6e8cb367dcc32e65f59ed4fe1..f6b7fc82d3d9116d63bd3e9bfe6523f355de2aea 100644 (file)
@@ -1,3 +1,8 @@
+From 4f196323aba5b0f49979826533c65633b8a9b6a2 Mon Sep 17 00:00:00 2001
+From: Richard Purdie <richard.purdie@linuxfoundation.org>
+Date: Fri, 7 Feb 2020 12:29:56 +0000
+Subject: [PATCH] libevdev: Fix determinism issue
+
 The order of dict values is not deterministic leading to differing header file generation.
 Sort to remove this inconsistency.
 
@@ -6,29 +11,33 @@ RP 2020/2/7
 Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
 Upstream-Status: Pending
 
-Index: a/libevdev/make-event-names.py
-===================================================================
+---
+ libevdev/make-event-names.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libevdev/make-event-names.py b/libevdev/make-event-names.py
+index 88addd7..c973e2a 100755
 --- a/libevdev/make-event-names.py
 +++ b/libevdev/make-event-names.py
-@@ -67,10 +67,10 @@ def print_bits(bits, prefix):
-       if  not hasattr(bits, prefix):
-               return
-       print("static const char * const %s_map[%s_MAX + 1] = {" % (prefix, prefix.upper()))
--      for val, name in list(getattr(bits, prefix).items()):
-+      for val, name in sorted(list(getattr(bits, prefix).items())):
-               print(" [%s] = \"%s\"," % (name, name))
-       if prefix == "key":
--              for val, name in list(getattr(bits, "btn").items()):
-+              for val, name in sorted(list(getattr(bits, "btn").items())):
-                       print(" [%s] = \"%s\"," % (name, name))
-       print("};")
-       print("")
-@@ -111,7 +111,7 @@ def print_lookup(bits, prefix):
-       if not hasattr(bits, prefix):
-               return
+@@ -70,10 +70,10 @@ def print_bits(bits, prefix):
+     if not hasattr(bits, prefix):
+         return
+     print("static const char * const %s_map[%s_MAX + 1] = {" % (prefix, prefix.upper()))
+-    for val, name in list(getattr(bits, prefix).items()):
++    for val, name in sorted(list(getattr(bits, prefix).items())):
+         print("    [%s] = \"%s\"," % (name, name))
+     if prefix == "key":
+-        for val, name in list(getattr(bits, "btn").items()):
++        for val, name in sorted(list(getattr(bits, "btn").items())):
+             print("    [%s] = \"%s\"," % (name, name))
+     print("};")
+     print("")
+@@ -118,7 +118,7 @@ def print_lookup(bits, prefix):
+     if not hasattr(bits, prefix):
+         return
  
--      names = list(getattr(bits, prefix).items())
-+      names = sorted(list(getattr(bits, prefix).items()))
-       if prefix == "btn":
-               names = names + btn_additional;
+-    names = list(getattr(bits, prefix).items())
++    names = sorted(list(getattr(bits, prefix).items()))
+     if prefix == "btn":
+         names = names + btn_additional
  
similarity index 78%
rename from meta/recipes-support/libevdev/libevdev_1.8.0.bb
rename to meta/recipes-support/libevdev/libevdev_1.9.0.bb
index 3523dc096899e7c99d8fd3d3516c7921b80b2db2..a2116a492f01bcd781e6c558167f37343c289adc 100644 (file)
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=75aae0d38feea6fda97ca381cb9132eb \
 
 SRC_URI = "http://www.freedesktop.org/software/libevdev/${BP}.tar.xz \
            file://determinism.patch"
-SRC_URI[md5sum] = "879631080be18526737e33b63d848039"
-SRC_URI[sha256sum] = "20d3cae4efd277f485abdf8f2a7c46588e539998b5a08c2c4d368218379d4211"
+SRC_URI[md5sum] = "13c3f0911f9326d4b9fa103365f84421"
+SRC_URI[sha256sum] = "e7e18a64264f2dea19b6c50a481f8c062529d42919ccda0bc861495bce28eb9e"
 
 inherit autotools pkgconfig