]> code.ossystems Code Review - openembedded-core.git/commitdiff
telepathy-glib: Use autotools_stage_all now (its been fixed)
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:58:37 +0000 (15:58 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:58:37 +0000 (15:58 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/telepathy/telepathy-glib_0.7.29.bb

index 4d143bac1191b2dfd24ee77df73108ce2822b8b0..44df34df6801423f5e8bf732cd862b2107fab993 100644 (file)
@@ -2,40 +2,12 @@ DESCRIPTION = "Telepathy Framework: GLib-based helper library for connection man
 HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
 DEPENDS = "glib-2.0 dbus python-native-runtime dbus-native dbus-glib"
 LICENSE = "LGPL"
+PR = "r1"
 
 SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz \
            file://prefer_python_2.5.patch;patch=1 "
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 FILES_${PN} += "${datadir}/telepathy \
                ${datadir}/dbus-1"
-
-do_stage() {
-       #
-       # copied autotools_stage_all because telepathy-glib has one lib only built as static
-       # so it can not be oe_libinstalled
-       #
-       rm -rf ${STAGE_TEMP}
-       mkdir -p ${STAGE_TEMP}
-       oe_runmake DESTDIR="${STAGE_TEMP}" install
-       if [ -d ${STAGE_TEMP}/${includedir} ]; then
-               cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
-       fi
-       if [ -d ${STAGE_TEMP}/${libdir} ]
-       then
-               for i in ${STAGE_TEMP}/${libdir}/*.la
-               do
-                       if [ ! -f "$i" ]; then
-                               cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
-                               break
-                       fi
-               done
-               oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
-       fi
-       if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
-               install -d ${STAGING_DATADIR}/aclocal
-               cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
-       fi
-       rm -rf ${STAGE_TEMP}
-}