]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpam: avoid overwritting editable files during package updating
authorJian Liu <jian.liu@windriver.com>
Fri, 21 Nov 2014 09:17:13 +0000 (17:17 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Dec 2014 12:22:41 +0000 (12:22 +0000)
Use CONFFILES to mark editable files as such,
  /etc/pam.d/common-session
  /etc/pam.d/common-auth
  /etc/pam.d/common-password
  /etc/pam.d/common-session-noninteractive
  /etc/pam.d/common-account

If there is no %config micro before the file name in the spec file,
this file will be overwritten after updating package.
This will make our settings lost.

Signed-off-by: Jian Liu <jian.liu@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/pam/libpam_1.1.6.bb

index 3b6d5144f922059432d387e8535e6830e93f0cdf..b3b39da864c50448bb72a9895615bfd69fd46c6c 100644 (file)
@@ -163,3 +163,9 @@ python do_pam_sanity () {
 addtask pam_sanity before do_configure
 
 BBCLASSEXTEND = "nativesdk native"
+
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-auth"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-password"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session-noninteractive"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-account"