]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr: remove obsolete support for renamed libtool
authorRoss Burton <ross@burtonini.com>
Fri, 10 Dec 2021 14:22:39 +0000 (14:22 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Dec 2021 18:10:09 +0000 (18:10 +0000)
libtool is now longer renamed to ${host}-libtool, so remove the changes
to support this.

This means that apr now installs libtool into the build-1 folder, but
as this has never been needed before (as we use the system libtool) we
can remove it (it contains build paths so is unreproducible).  Also add
a RDEPENDS on libtool for the target -dev package.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/apr/apr_1.7.0.bb

index 5f8fd6a4618996238d4731eece3589a82747051b..9c826d4380753a8149f9e190fb4b397f2a5baf92 100644 (file)
@@ -63,7 +63,7 @@ MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
                     ${PN}-dev:${datadir}/build-1/apr_rules.mk"
 
 FILES:${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
-RDEPENDS:${PN}-dev += "bash"
+RDEPENDS:${PN}-dev += "bash libtool"
 
 RDEPENDS:${PN}-ptest += "libgcc"
 
@@ -80,6 +80,8 @@ do_install:append() {
 }
 
 do_install:append:class-target() {
+       rm -f ${D}${datadir}/build-1/libtool
+       sed -i s,LIBTOOL=.*,LIBTOOL=libtool,g ${D}${datadir}/build-1/apr_rules.mk
        sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
               -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
        sed -i -e 's,${STAGING_DIR_HOST},,g' \
@@ -97,12 +99,12 @@ apr_sysroot_preprocess () {
        cp ${S}/build/apr_rules.mk $d/
        sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
        sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
-       sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
+       sed -i s,LIBTOOL=.*,LIBTOOL=libtool,g $d/apr_rules.mk
        sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
        cp ${S}/build/mkdir.sh $d/
        cp ${S}/build/make_exports.awk $d/
        cp ${S}/build/make_var_export.awk $d/
-       cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
+       cp ${S}/libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
 }
 
 do_compile_ptest() {