]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: Add pathfix patch
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 3 Oct 2020 16:27:10 +0000 (17:27 +0100)
committerSteve Sakoman <steve@sakoman.com>
Thu, 28 Jan 2021 14:41:47 +0000 (04:41 -1000)
Add a path to fix up handling of dirfd being passed as a full file
and with path="".

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 3006bbe7768e4efe33d3d2d3f5786a561ecbe96f)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/pseudo/files/pathfix.patch [new file with mode: 0644]
meta/recipes-devtools/pseudo/pseudo_git.bb

diff --git a/meta/recipes-devtools/pseudo/files/pathfix.patch b/meta/recipes-devtools/pseudo/files/pathfix.patch
new file mode 100644 (file)
index 0000000..b3e63fa
--- /dev/null
@@ -0,0 +1,25 @@
+We're seeing systems in the wild (e.g. ubuntu 20.04) which call
+with a dirfd set to the full filename and path set to "". Since
+this seems to be expected to work, handle it accordingly.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Upstream-Status: Pending
+
+Index: git/pseudo_client.c
+===================================================================
+--- git.orig/pseudo_client.c
++++ git/pseudo_client.c
+@@ -1549,8 +1549,12 @@ base_path(int dirfd, const char *path, i
+       if (!path)
+               return NULL;
+-      if (!*path)
++
++      if (!*path) {
++              if (dirfd != -1 && dirfd != AT_FDCWD)
++                      return fd_path(dirfd);
+               return "";
++      }
+       if (path[0] != '/') {
+               if (dirfd != -1 && dirfd != AT_FDCWD) {
index c5040f5f7f756f99a92936d3d43f0507b8dba063..bc20a2f134e4fc3f0660ec37c7a05587bf059138 100644 (file)
@@ -8,6 +8,7 @@ SRC_URI = "git://git.yoctoproject.org/pseudo;branch=oe-core \
            file://track_link_fds.patch \
            file://xattr_fix.patch \
            file://mayunlink.patch \
+           file://pathfix.patch \
            file://fallback-passwd \
            file://fallback-group \
            "